postfix pop3 / IMAP authentication & maildrop problem

Discussion in 'HOWTO-Related Questions' started by jayesha, Jun 29, 2008.

  1. jayesha

    jayesha New Member

    Dear all ,

    I am trying to install the postfix from howtoforge link from 3-5 days http://www.howtoforge.com/virtual_users_postfix_courier_mailscanner_clamav_centos but I followed the same URL , but getting some problems ... how to fix it ? i am not getting any way . I am very sorry for my below log post but it will clear my config mistake if any ..
    Please help & guid me ,
    OS :-- CentOS release 4.4 2.6.9-42.EL i686 i686 i386 GNU/Linux

    1) when I set "virtual_transport = virtual" my emails are follwing perfect , But as per documentation when i set "virtual_transport = maildrop" mails are getting queue with error as follows

    Jun 29 16:11:06 mail postfix/smtpd[25009]: connect from localhost.localdomain[127.0.0.1]
    Jun 29 16:11:07 mail postfix/smtpd[25009]: 3DCC82814F: client=localhost.localdomain[127.0.0.1]
    Jun 29 16:11:07 mail postfix/cleanup[25017]: 3DCC82814F: message-id=<[email protected]>
    Jun 29 16:11:07 mail postfix/qmgr[24993]: 3DCC82814F: from=<[email protected]>, size=404, nrcpt=1 (queue active)
    Jun 29 16:11:07 mail postfix/smtpd[25009]: disconnect from localhost.localdomain[127.0.0.1]
    Jun 29 16:11:07 mail maildrop[25020]: Unable to create log file.
    Jun 29 16:11:07 mail postfix/pipe[25019]: 3DCC82814F: to=<[email protected]>, relay=maildrop, delay=1, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to create log file. )

    what could be reason and solution ?

    2) At which line "/usr/sbin/maildirmake.sh & /usr/sbin/maildirdel.sh " related line need to be put in "create-mailbox.php" "delete.php" of postfixadmin ?

    3) when i am trying to telnet port 110 or trying to loging via webmail ( imap 143) , I am getting auth fail error as follows
    [[email protected] ~]# telnet 127.0.0.1 110
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    +OK Hello there.
    user [email protected]
    +OK Password required.
    pass test2
    -ERR Login failed.
    log :--
    Jun 29 16:48:00 mail pop3d: Connection, ip=[::ffff:127.0.0.1]
    Jun 29 16:48:17 mail pop3d: LOGIN FAILED, [email protected], ip=[::ffff:127.0.0.1]

    similarly when i do following i am getting error as followes

    [[email protected] ~]# /usr/sbin/authtest [email protected] test2
    Authentication FAILED: Operation not permitted
    log :--
    Jun 29 16:56:04 mail pop3d: Disconnected, ip=[::ffff:10.15.63.250]

    my config files are as followes :--
    ========================

    -rw-r----- 1 root vmail 201 Jun 29 14:09 /usr/lib/sasl2/smtpd.conf

    cat /usr/lib/sasl2/smtpd.conf

    #pwcheck_method: saslauthd
    # smtpd.conf
    pwcheck_method: authdaemond
    log_level: 3
    mech_list: PLAIN LOGIN
    #authdaemond_path:/usr/var/spool/authdaemon/socket
    authdaemond_path:/var/spool/authdaemon/socket

    drwxr-xr-x 2 daemon daemon 4096 Jun 29 13:54 /var/spool/authdaemon/
    ----------------------------------------------------------------------------------------------------------------------------------
    -rw-rw---- 1 daemon daemon 3875 Jun 28 23:30 /etc/authlib/authdaemonrc

    cat /etc/authlib/authdaemonrc

    authmodulelist="authmysql"
    authmodulelistorig="authuserdb authpam authpgsql authldap authmysql authcustom authpipe"
    daemons=5
    authdaemonvar=/var/spool/authdaemon
    DEBUG_LOGIN=1
    DEBUG_LOGIN=2
    DEBUG_LOGIN=0
    DEFAULTOPTIONS="wbnochangepass=1,wbusexsender=1,disableshared=1"
    LOGGEROPTS=""
    -----------------------------------------------------------------------------------------------------------------------------------
    -r-------- 1 daemon daemon 9947 Jun 28 23:05 /etc/authlib/authmysqlrc

    cat /etc/authlib/authmysqlrc

    MYSQL_SERVER localhost
    MYSQL_USERNAME root
    MYSQL_PASSWORD password123
    MYSQL_SOCKET /var/lib/mysql/mysql.sock
    MYSQL_PORT 0
    MYSQL_OPT 0
    MYSQL_DATABASE postfix
    MYSQL_USER_TABLE mailbox
    MYSQL_CRYPT_PWFIELD password
    MYSQL_CLEAR_PWFIELD password
    MYSQL_UID_FIELD '1001'
    MYSQL_GID_FIELD '1001'
    MYSQL_LOGIN_FIELD username
    MYSQL_HOME_FIELD '/opt/mail'
    MYSQL_NAME_FIELD name
    MYSQL_MAILDIR_FIELD CONCAT("/opt/mail/",maildir)
    MYSQL_QUOTA_FIELD concat(quota,'S')
    ---------------------------------------------------------------------------------------------------------------------------------
    -rw------- 1 bin bin 13832 Jun 29 00:15 /usr/lib/courier-imap/etc/imapd

    cat /usr/lib/courier-imap/etc/imapd

    ADDRESS=127.0.0.1
    PORT=143
    MAXDAEMONS=40
    MAXPERIP=20
    PIDFILE=/var/run/imapd.pid
    TCPDOPTS="-nodnslookup -noidentlookup"
    LOGGEROPTS="-name=imapd"
    IMAP_CAPABILITY="IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA AUTH=CRAM-MD5 AUTH=CRAM-SHA1 AUTH=PLAIN AUTH=LOGIN IDLE"
    IMAP_KEYWORDS=1
    IMAP_ACL=0
    IMAP_CAPABILITY_ORIG="IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA AUTH=CRAM-MD5 AUTH=CRAM-SHA1 AUTH=CRAM-SHA256 IDLE"
    IMAP_PROXY=0
    IMAP_PROXY_FOREIGN=0
    IMAP_IDLE_TIMEOUT=60
    IMAP_CAPABILITY_TLS="$IMAP_CAPABILITY"
    IMAP_CAPABILITY_TLS_ORIG="$IMAP_CAPABILITY_ORIG AUTH=PLAIN"
    IMAP_DISABLETHREADSORT=0
    IMAP_CHECK_ALL_FOLDERS=0
    IMAP_OBSOLETE_CLIENT=0
    IMAP_UMASK=022
    IMAP_ULIMITD=65536
    IMAP_USELOCKS=1
    IMAP_SHAREDINDEXFILE=/usr/lib/courier-imap/etc/shared/index
    IMAP_ENHANCEDIDLE=1
    IMAP_TRASHFOLDERNAME=Trash
    IMAP_MOVE_EXPUNGE_TO_TRASH=0
    SENDMAIL=/usr/sbin/sendmail
    HEADERFROM=X-IMAP-Sender
    IMAPDSTART=YES
    MAILDIRPATH=/opt/mail/
    --------------------------------------------------------------------------------------------------------------------------------
    -rw------- 1 bin bin 7901 Jun 29 00:16 /usr/lib/courier-imap/etc/imapd-ssl

    cat /usr/lib/courier-imap/etc/imapd-ssl

    SSLPORT=993
    SSLADDRESS=0
    SSLPIDFILE=/var/run/imapd-ssl.pid
    SSLLOGGEROPTS="-name=imapd-ssl"
    IMAPDSSLSTART=YES
    IMAPDSTARTTLS=YES
    IMAP_TLS_REQUIRED=0
    COURIERTLS=/usr/lib/courier-imap/bin/couriertls
    TLS_PROTOCOL=SSL3
    TLS_STARTTLS_PROTOCOL=TLS1
    TLS_CERTFILE=/usr/local/ssl/mail.yourdomain.com.pem
    TLS_VERIFYPEER=NONE
    TLS_CACHEFILE=/var/run/couriersslcache
    TLS_CACHESIZE=524288
    MAILDIRPATH=/opt/mail/
    ---------------------------------------------------------------------------------------------------------------------------------

    -rw------- 1 bin bin 3442 Jun 29 00:14 /usr/lib/courier-imap/etc/pop3d

    cat /usr/lib/courier-imap/etc/pop3d
    PIDFILE=/var/run/pop3d.pid
    MAXDAEMONS=40
    MAXPERIP=4
    POP3AUTH="CRAM-MD5 CRAM-SHA1 PLAIN LOGIN"
    POP3AUTH_ORIG="PLAIN LOGIN CRAM-MD5 CRAM-SHA1 CRAM-SHA256"
    POP3AUTH_TLS="$POP3AUTH"
    POP3AUTH_TLS_ORIG="LOGIN PLAIN"
    POP3_PROXY=0
    PORT=110
    ADDRESS=0
    TCPDOPTS="-nodnslookup -noidentlookup"
    LOGGEROPTS="-name=pop3d"
    POP3DSTART=YES
    MAILDIRPATH=/opt/mail/
    --------------------------------------------------------------------------------------------------------------------------------
    -rw------- 1 bin bin 7440 Jun 29 00:14 /usr/lib/courier-imap/etc/pop3d-ssl
    cat /usr/lib/courier-imap/etc/pop3d-ssl

    SSLPORT=995
    SSLADDRESS=0
    SSLPIDFILE=/var/run/pop3d-ssl.pid
    SSLLOGGEROPTS="-name=pop3d-ssl"
    POP3DSSLSTART=YES
    POP3_STARTTLS=YES
    POP3_TLS_REQUIRED=0
    COURIERTLS=/usr/lib/courier-imap/bin/couriertls
    TLS_PROTOCOL=SSL3
    TLS_STARTTLS_PROTOCOL=TLS1
    TLS_CERTFILE=/usr/local/ssl/mail.yourdomain.com.pem
    TLS_VERIFYPEER=NONE
    TLS_CACHEFILE=/var/run/couriersslcache
    TLS_CACHESIZE=524288
    MAILDIRPATH=/opt/mail/

    Please guide and help for above 3 problems.

    Thank & Regards
    Jayesh Shinde
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Where's the Maildrop log directory? What permissions does it have?
     
  3. jayesha

    jayesha New Member

    Hi falko ,

    Thanks for you reply . My 1st problem is solved now , it was the file ownership problem , I changed the ownership from "root" to "vmail" and is woking perfect with "virtual_transport = maildrop" .

    Maildrop log directory is /var/log/

    [[email protected] ~]# ls -l /var/log/maildroprc.log
    -rw-r--r-- 1 vmail vmail 459 Jul 1 08:33 /var/log/maildroprc.log


    But what could be reason that i am getting login faild form 110 / 143 i.e pop & imap ?

    IF you see in my below posted config file i have only changed the "authdaemond_path" as
    #authdaemond_path:/usr/var/spool/authdaemon/socket
    authdaemond_path:/var/spool/authdaemon/socket

    This is because in my case the "socket" is inside the /var/spoo/authdaemon/ directory

    I checked with "/usr/var/spool/authdaemon/socket" path too but still no luck.

    Do I need to add any more parameter setting in below config file or it is file permission issue. what I am missing for pop3 and imap ?

    Thanks & Regards
    Jayesh Shinde
     
  4. jayesha

    jayesha New Member

    Dear all ,

    I think i am missing something about authdeamon with mysql . Because when I configure one account in Evolution , I am getting following error in /var/log/maillog
    ####
    Jul 1 13:47:27 mail pop3d: Disconnected, ip=[::ffff:10.15.63.250]
    Jul 1 13:47:29 mail postfix/smtpd[24901]: warning: SASL authentication failure: Password verification failed
    ####

    After searching in Google , now i have changed following parameter as in below file
    -r-------- 1 daemon daemon 9947 Jun 28 23:05 /etc/authlib/authmysqlrc
    cat /etc/authlib/authmysqlrc

    MYSQL_SERVER localhost
    MYSQL_USERNAME postfix
    MYSQL_PASSWORD postfix
    I am using postfixadmin postfixadmin-2.1.0 and so in mysql "postfix" name database is present and for this username is "postfix" password "postfix" ( as default mention in DATABASE_MYSQL.TXT file of postfix admin )

    And the same db , username , password is using in all /etc/postfix/*.cf ( as mention in how-to documnetation )

    user = postfix
    password = postfix
    hosts = localhost
    dbname = postfix

    what configuration i am missing for authentication , so that smtpauth , pop and imap will get work ? Is any one gone through this problem if yes please help and guide me .

    Thanks & Regards
    Jayesh Shinde
     

Share This Page