postfix on dynamic iP ?

Discussion in 'Server Operation' started by soroccoheaven, Oct 6, 2007.

  1. soroccoheaven

    soroccoheaven New Member


    I have configured postfix last month ...for my local lan i want to configure it for my website hosted on dynamic Ip and using to do this ?..can i configure it for local as well as internet simultaneously ?..
    i made some changes as and but no go.

    i am using google mail as realaying server ..but i can see all the mail going to google with my local domain name
    [email protected] (configured for lacal lan).
    so reported as:

    Oct 6 16:17:55 serv postfix/smtp[16195]: A3C088C11C: to=<[email protected]>,[], delay=6, status=bounced (host[] said: 553 5.5.3 <[email protected]>... Invalid (in reply to RCPT TO command))

    pls. advice.

  2. falko

    falko Super Moderator ISPConfig Developer

    Create MX records for your email domains that point to your DynDNS address.

    What's in your /etc/postfix/
  3. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Even it does not helpd for your problem, I would never run a mailserver on a dynamic IP.
    A server shall have a static IP especially in times of SPAM, so many ppl drop mails from dialup hosts (having dynamic IPs), so do I.
  4. chuckl

    chuckl New Member

  5. soroccoheaven

    soroccoheaven New Member

    myorigin = $mydomain
    mydomain = lin.ald
    myhostname = serv.$mydomain
    inet_interfaces = all
    mynetworks_style = class
    mynetworks =,
    delay_warning_time = 4h
    relayhost =
    smtpd_banner = $myhostname ESMTP $mail_name ($mail_version) (Mandrake Linux)
    unknown_local_recipient_reject_code = 450
    smtp-filter_destination_concurrency_limit = 2
    lmtp-filter_destination_concurrency_limit = 2
    smtpd_sasl_path = /etc/postfix/sasl:/usr/lib/sasl2
    recipient_delimiter = +
    owner_request_special = no
    alias_maps = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    #smtpd_sasl_security_options = noanonymous
    smtpd_sasl_security_options =
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,rejec

    what will be the mydoain and myhostname ?.... i have tried with my domain name from dyndns but not worked.
  6. soroccoheaven

    soroccoheaven New Member

    ok.. let me explain about the problem more briefly.

    i am running a web server apache ..with dyndns as
    with postfix, squirrel mail ..
    1. My host name is serv.lin.ald
    when someone type can see it. and my web forms and comments are forwarded to smtp server.i use squirrel mail to see them.
    i can send/receive mail to all the local accoounts .
    now can i use something like say [email protected]
    instead of [email protected] because i can not use serv.lin.ald for internet mail.
    for this i made changes in and squirrel mail (./configure) but imap error at login.php....when this whole setup was done it wasnt for internet ..but now because i am running web server my mail need to be forwarded to respective mail server.

    @Falko are right about the MX record ..but i am not able understand it how and where to include these records (which zone file).I have manged to configure a dns (bind) for local lan ..

    so do i need to change
    1. my hostname from serv.lin.ald to ?
    2. change for mydomain as , myhostname as in
    3. Changes in sqquirrelmail ?
    4. MX entry in dns zone. ?

    pls advice.

  7. falko

    falko Super Moderator ISPConfig Developer

    I'd use for myorigin, mydomain, and myhostname.

    Make sure that you set the correct sender address in your email client so that Google accepts the mail.
  8. soroccoheaven

    soroccoheaven New Member

    Thanks falko..but no its not working ..with as my origin,mydomain and i have to include my destinations option in ?

    one more thing ..whenever i change the imap and smtp setting (through ./configure) in squirrel as domain i get permission denied error during login process (login.php) ....
    see the error messages ....mail going with @serv.lin.ald.. thats the problem ..
    how to make them as say if it goes with will it be acceptable d by gmail ?
    Oct 10 00:02:59 serv postfix/smtp[23603]: 7885C8C132: to=<[email protected]>,[], delay=4, status=bounced (host[] said: 553 5.5.3 <[email protected]>... Invalid (in reply to RCPT TO command))
    Oct 10 00:02:59 serv postfix/qmgr[23557]: 7885C8C132: removed
    now whats next ..???...
  9. falko

    falko Super Moderator ISPConfig Developer

    lin.ald is not a real domain...
  10. soroccoheaven

    soroccoheaven New Member

    ya..its known to me ..thats why i want it as [email protected] ..but what configuration changes are required to get the am not able to change serv.lin.ald ..
    1. I have changed in mydomain,my origin,myhostname as .
    2. changes in squirrel mail domain name ,smtp and Imap server update setting as
    anything else needed to be changed ?

  11. falko

    falko Super Moderator ISPConfig Developer

  12. soroccoheaven

    soroccoheaven New Member

    email client ? and what do mean by email client..of course i am using squirrel mail to change this serv.lin.ald to in squirrel mail..of course after modification in ..pls advice.

    Last edited: Oct 10, 2007
  13. falko

    falko Super Moderator ISPConfig Developer

    Outlook, Thunderbird, Squirrelmail, etc. are all email clients.

    When you're logged in in Squirrelmail, you can change the sender address in the preferences.

Share This Page