Postfix not receive but send mail !!!

Discussion in 'Installation/Configuration' started by mixian, Jul 5, 2010.

  1. mixian

    mixian New Member

    Hi,
    i have installed succesfully ispConfig 3.
    I'm very happy...dns server, slave with mydnsconfig, synchro, etc...

    I' have installed Postfix with Roundcube.
    I' have unblocked my firewall ports (110,143,993,995) on my amazon elastic fox interface.
    I'm able to send correctly all mail but i not receive from any host.

    I'have correctely configured DNS service on MX field and the dig command point to correct IP address.

    I note that in the default folder of COURIER DAEMON any mail is present:

    /var/vmail/DOMAIN/ACCOUNT/new

    and in the log any message of error is present and any mail return to sender.

    I try to sen mail from QMAIL server (my other server with plesk) and the mail return with this message:

    "This address no longer accepts mail"

    I do not understand what's the problem....postfix configuration ? IspConfig? Roundcube? Courier daemon conlict ?

    I use imapd and pop3d both ? But interest is only for pop3.

    Thanks.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the exact error messages from the mail log.
     
  3. mixian

    mixian New Member

    hi,
    i try to send from rondcube (mixian.it to gmail.com) and i see in the log...but the response in not present in the log...

    Jul 5 17:30:52 ns1 amavis[835]: (00835-05) Passed CLEAN, <info@mixian.it> -> <mixian@gmail.com>, Message-ID: <8394cf32187c61e3e104a844fd5deb8d@localhost>, mail_id: 9ten4MHYkxPo, Hits: 2.357, size: 746, queued_as: E2B618E6DB, 573 ms
    Jul 5 17:30:52 ns1 postfix/smtp[20712]: 5623B8E6E3: to=<mixian@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.7, delays=0.11/0.01/0/0.58, dsn=2.0.0, status=sent
    (250 2.0.0 Ok, id=00835-05, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as E2B618E6DB)
    Jul 5 17:30:52 ns1 postfix/smtpd[20715]: disconnect from localhost.localdomain[127.0.0.1]
    Jul 5 17:30:52 ns1 postfix/qmgr[16167]: 5623B8E6E3: removed
    Jul 5 17:30:53 ns1 postfix/qmgr[16167]: E2B618E6DB: from=<info@mixian.it>, size=1188, nrcpt=1 (queue active)
    Jul 5 17:30:53 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Jul 5 17:30:53 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[50110], protocol=IMAP
    Jul 5 17:30:53 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=10, sent=83, time=0
    Jul 5 17:30:53 ns1 postfix/smtp[20718]: E2B618E6DB: to=<mixian@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.77.27]:25, delay=1, delays=0.06/0.02/0.27/0.65, dsn=2.0.0, status=sent (250 2.0.0 OK 1278343853 a59si10461500eei.16)
    Jul 5 17:30:53 ns1 postfix/qmgr[16167]: E2B618E6DB: removed
    Jul 5 17:31:42 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Jul 5 17:31:42 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[50111], protocol=IMAP
    Jul 5 17:31:42 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=232, body=0, rcvd=288, sent=940, time=0
    Jul 5 17:31:53 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Jul 5 17:31:53 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[50113], protocol=IMAP
    Jul 5 17:31:53 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=61, sent=368, time=0
    Jul 5 17:32:25 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Jul 5 17:32:25 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[39496], protocol=IMAP
    Jul 5 17:32:25 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=81, sent=413, time=0
    Jul 5 17:32:27 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Jul 5 17:32:27 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[39498], protocol=IMAP
    Jul 5 17:36:38 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Jul 5 17:36:38 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[39545], protocol=IMAP
    Jul 5 17:36:38 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=56, sent=368, time=0
    ns1:/var/www/rcmail/config#
     
  4. mixian

    mixian New Member

    Another think...

    if i send a mail from roundcube account to same roundcube account (from same domain that i have crate with ispconfig), i send and receive mail.

    I receive mail only if the sender is an local domain / account!
     
  5. Mark_NL

    Mark_NL New Member

    have you opened port 25?
     
  6. mixian

    mixian New Member

    OPS, the learning never ends!
    Thanks.

    I assumed (wrongly) that port 25 was only for outgoing mail.
    SMTP but probably has a different meaning:)
     
  7. mixian

    mixian New Member

    Hi,
    i transfer all mail account from /var/vmail/ to /mnt/var/vmail because is more space for massive email.

    In the IspConfig panel i have changed two field:

    - Mail dir path = /mnt/var/vmail/[domain]/[localpart]
    - Home dir = /mnt/var/vmail

    is correct or more configuration is necessary because as it seems not to receive any emails ?


    Thanks.
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please undo this. Then stop postfix and courier and run:

    mv /var/vmail /var/vmail_old

    now mount the new harddiks partition as /var/vmail and move the data back to this partition. There is no need to change any paths.
     
  9. Mark_NL

    Mark_NL New Member

    appendix ;-)

    indeed, mount the disc under /var/vmail

    (if your new disc is sdb with one partition)

    edit /etc/fstab and add the line:

    Code:
    /dev/sdb1 /var/vmail ext3 defaults 0 0
    then: mount /var/vmail

    and now move the content of /var/vmail_old to /var/vmail

    and you're good to go (no changes to ispconfig needed this way) :)
     
  10. mixian

    mixian New Member

    i try....i not able to work with fstab :)

    # Legacy /etc/fstab
    # Supplied by: ec2-ami-tools-1.3-45758

    /dev/sda1 / ext3 errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 1

    /dev/sda2 /mnt ext3 defaults 0 0

    /dev/sda3 swap swap defaults 0 0

    /dev/sda2 /mnt/var/vmail ext3 default 0 0 ############ MY LINE

    none /proc proc defaults 0 0
    none /sys sysfs defaults 0 0
     
    Last edited: Jul 6, 2010
  11. Mark_NL

    Mark_NL New Member

    nono wait ..

    show me what the following command returns:
    Code:
    cat /proc/mounts
     
  12. mixian

    mixian New Member

    ns1:/mnt/var/vmail# cat /proc/mounts
    rootfs / rootfs rw 0 0
    /dev/root / ext3 rw,data=ordered,jqfmt=vfsv0,usrjquota=aquota.user,grpjquota=aquota.group 0 0
    /dev /dev tmpfs rw 0 0
    /proc /proc proc rw 0 0
    /sys /sys sysfs rw 0 0
    none /selinux selinuxfs rw 0 0
    tmpfs /lib/init/rw tmpfs rw,nosuid 0 0
    usbfs /proc/bus/usb usbfs rw,nosuid,nodev,noexec 0 0
    tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
    devpts /dev/pts devpts rw,nosuid,noexec 0 0
    /dev/sda2 /mnt ext3 rw,data=ordered 0 0
    ns1:/mnt/var/vmail#

    my big partition is sda2

    please see my last post....i have modify it...
     
    Last edited: Jul 6, 2010
  13. Mark_NL

    Mark_NL New Member

    Before you start doing the stuff below, is there anything else on sda2, or is it empty?


    1. move the contents back from /mnt/var/vmail to /var/vmail
    Code:
    mv /mnt/var/vmail/* /var/vmail/
    2. rename the dir /var/vmail to /var/vmail_old
    Code:
    mv /var/vmail /var/vmail_old
    3. create a dir /var/vmail
    Code:
    mkdir /var/vmail
    4. unmount your drive from /mnt
    Code:
    umount /mnt
    5. edit /etc/fstab and give it this content:
    Code:
    /dev/sda1 / ext3 errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jq fmt=vfsv0 0 1
    /dev/sda2 /var/vmail ext3 default 0 0
    /dev/sda3 swap swap defaults 0 0
    none /proc proc defaults 0 0
    none /sys sysfs defaults 0 0
    6. type:
    Code:
    mount -a
    7. move the content of vmail_old to /var/vmail
    Code:
    mv /var/vmail_old/* /var/vmail/
     
  14. mixian

    mixian New Member

    there is only a "lost+found" directory (empty)

    and

    "umount /mnt" command FAIL....device is busy.

    Is amazon issue ?!?!

    Any application or service is active on /mnt.

    ns1:/mnt# fuser -m /mnt/
    /mnt/: 15020c 15752c 15753c 15955c 15956c 16413c 16740c

    ns1:/mnt#

    ?!????!?!!?!
     
    Last edited: Jul 6, 2010
  15. Mark_NL

    Mark_NL New Member

    ns1:/mnt#

    you're inside /mnt .. you cannot unmount when you're inside the /mnt folder .. so

    cd /;; umount /mnt
     
  16. mixian

    mixian New Member

    Excuse me for my stupid error :)

    ok the procedure but now the incoming messages remaining in the Maildir file and not result in the inbox of account
     
  17. Mark_NL

    Mark_NL New Member

    Sorry, could you elaborate this? i have no idea what you're saying :)
     
  18. mixian

    mixian New Member

    After following the procedure no longer receiving mail.
    I noticed that remain in a file (/ var / vmail / Maildir) concatenated one after another, instead of being moved to the correct file.

    I have also reassigned the permissions to folder as before.

    Thanks for your patience and sorry for my bad English.
     
  19. Mark_NL

    Mark_NL New Member

    Ehm, after you have moved the /var/vmail_old to /var/vmail ..

    in the /var/vmail dir, you should have your domains as directories, in it the names of the users f.e.:

    /var/vmail/domain.tld/info/ <-- this dir should contain the new / cur / etc dirs just like a Maildir dir.

    if you create a guest account for me, and send me the info in a pm, i can have a look at it, and give you better instructions, let me know if you're up for that.
     
  20. mixian

    mixian New Member

    Before doing this, I want you to note that in a previous post voltron81 had the same problem.
    Transfer / var / vmail is corrupt. Mailfilter files! and the message remains in / var / vmail / Maildir files.

    The post:

    http://www.howtoforge.com/forums/showthread.php?t=40928

    My /var/vmail :


    #################
    ns1:/var/vmail# ls -la
    total 28
    drwxr-xr-x 3 vmail vmail 4096 Jul 7 12:01 .
    drwxr-xr-x 17 root root 4096 Jul 6 14:34 ..
    -rw------- 1 vmail vmail 13141 Jul 7 10:28 Maildir
    drwxr-xr-x 3 vmail vmail 4096 Jul 7 01:40 domain.ltd
    ns1:/var/vmail#

    N.B. In Maildir file there are all the emails that are not displayed in the mailbox info@domain.tld

    #################
    ns1:/var/vmail/domain.ltd# ls -la
    total 12
    drwxr-xr-x 3 vmail vmail 4096 Jul 7 01:40 .
    drwxr-xr-x 3 vmail vmail 4096 Jul 7 12:01 ..
    drwx------ 10 vmail vmail 4096 Jul 7 01:40 info
    ns1:/var/vmail/domain.ltd#

    #################
    ns1:/var/vmail/domain.ltd/info# ls -la
    total 56
    drwx------ 10 vmail vmail 4096 Jul 7 01:40 .
    drwxr-xr-x 3 vmail vmail 4096 Jul 7 01:40 ..
    drwx------ 6 vmail vmail 4096 Jul 7 01:40 .Drafts
    drwx------ 6 vmail vmail 4096 Jul 7 01:40 .Junk
    drwx------ 6 vmail vmail 4096 Jul 7 01:40 .Sent
    drwx------ 6 vmail vmail 4096 Jul 7 01:40 .Trash
    drwx------ 2 vmail vmail 4096 Jul 7 01:40 courierimapkeywords
    -rw-r--r-- 1 vmail vmail 48 Jul 7 01:40 courierimapsubscribed
    -rw-r--r-- 1 vmail vmail 94 Jul 7 11:07 courierimapuiddb
    drwx------ 2 vmail vmail 4096 Jul 7 11:07 cur
    -rw-r--r-- 1 vmail vmail 191 Jul 7 11:07 maildirsize
    drwx------ 2 vmail vmail 4096 Jul 7 01:48 new
    -rw-r--r-- 1 vmail vmail 24 Jul 7 01:40 subscriptions
    drwx------ 2 vmail vmail 4096 Jul 7 11:07 tmp
    ns1:/var/vmail/domain.ltd/info#
     

Share This Page