Postfix not delivering outcoming mails.

Discussion in 'HOWTO-Related Questions' started by i_will3, Nov 17, 2009.

  1. i_will3

    i_will3 New Member

    Hello everybody,

    I 've been using Postfix there has been while and I got a complication I can't work out...

    I use fedora core 8 and here is my problem:

    It started yesterday after I installed postfixadmin ,for every virtual domain I host I can't anymore receive any mail from yahoo or hotmail even gmail but I can send with no problem.

    Here is what I get with postconf -n:
    *--------------------------------------------*
    alias_maps = hash:/etc/aliases
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    header_checks = regexp:/etc/postfix/header_checks
    html_directory = no
    inet_interfaces = all
    mail_owner = postfix
    mailbox_command = /usr/bin/procmail
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
    mydomain = domain.tld
    myhostname = mail.domain.tld
    mynetworks = 196.2.0.0/16, 127.0.0.0/8
    myorigin = $mydomain
    newaliases_path = /usr/bin/newaliases.postfix
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.3.6/README_FILES
    relayhost = [cni.cbinf.com]
    sample_directory = /usr/share/doc/postfix-2.3.6/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    unknown_local_recipient_reject_code = 550
    virtual_alias_domains = likob.bi
    virtual_alias_maps = hash:/etc/postfix/virtual
    *-------------------------------------------------------------*

    Here is what I get from my mail log in /var/log/maillog when I try to send an email to a one of the virtual domain hosted on my server

    NOQUEUE: reject: RCPT from ey-out-1920.google.com[74.125.78.150]: 554 5.7.1 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<ey-out-1920.google.com>
    Nov 17 19:38:47 mail postfix/smtpd[8757]: disconnect from ey-out-1920.google.com[74.125.78.150]


    Any help ?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    I guess virtualdomain.tld should be listed under virtual_alias_domains as well.
     
  3. i_will3

    i_will3 New Member

    hello,

    I finally came throughout this,it is something like what you say falko.

    I also noticed that virtualdomain.tld and others domains weren't listed on what I was getting with postconf-n ,and I also guessed that the messages for likob.bi were well delivered.

    In main.cf ,for every virtual domain I would like to host ,I was adding those lines:
    virtual_alias_domains=domain.tld
    virtual_alias_maps=hash:/etc/postfix/virtual

    I changed this way by adding only these 2 lines:

    virtual_alias_domains=hash:/etc/postfix/virtual_alias_domains
    virtual_alias_maps=hash:/etc/postfix/virtual


    and I created the file /etc/postfix/virtual_alias_domains
    which is in this format (domain date) ,the date is not necessary.

    domain1.tld 20091118
    domain2.tld 20091118

    Don't forget postmap hash:/etc/postfix/virtual_alias_domains and of course the postfix reload.

    And it worked:p ,so from now on, every virtual domain I want to host I only add it in /etc/ postfix/virtual_alias_domains and I make the mappings in /etc/postfix/virtual ,followed with postmap.
     

Share This Page