Postfix not delivering mail received

Discussion in 'Server Operation' started by White, Nov 27, 2011.

  1. White

    White Member

    I have read up on many posts to do with postfix not delivering emails and have posted this on someone elses thread so im starting my own for help

    I am running debian lenny from the perfect server setup, i have followed the tutorial for setting up postfix mysql and virtual users and have 7 sites running on my server. (NO ispconfig)

    I CANNOT RECIEVE EMAILS FROM OUTSIDE THE SERVER. the mail log says user unknown and bounces all email attempts.

    all my sites can send emails to each other, to gmail,hotmail,yahoo etc but none of the accounts will recieve.

    The emails are arriving at the server but my server is rejecting them as user unknown

    i have checked main.cf for example.com as i have it in mysql virtual db and it is server1.example.com

    here is the result of netstat -tap
    PHP:
    server1:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 
    *:41287                 *:*                     LISTEN      3037/rpc.statd  
    tcp        0      0 localhost
    .localdo:10024 *:*                     LISTEN      3437/amavisd (maste
    tcp        0      0 localhost
    .localdo:10025 *:*                     LISTEN      14949/master    
    tcp        0      0 localhost
    .localdo:mysql *:*                     LISTEN      3592/mysqld     
    tcp        0      0 
    *:sunrpc                *:*                     LISTEN      3026/portmap    
    tcp        0      0 server1
    .local:domain    *:*                     LISTEN      3392/named      
    tcp        0      0 localhost
    .locald:domain *:*                     LISTEN      3392/named      
    tcp        0      0 
    *:ssh                   *:*                     LISTEN      3409/sshd       
    tcp        0      0 localhost
    .localdoma:ipp *:*                     LISTEN      4289/cupsd      
    tcp        0      0 
    *:smtp                  *:*                     LISTEN      14949/master    
    tcp        0      0 localhost
    .localdoma:953 *:*                     LISTEN      3392/named      
    tcp6       0      0 
    [::]:imaps              [::]:*                  LISTEN      4184/couriertcpd
    tcp6       0      0 
    [::]:pop3s              [::]:*                  LISTEN      4207/couriertcpd
    tcp6       0      0 
    [::]:5900               [::]:*                  LISTEN      12406/vino-server
    tcp6       0      0 
    [::]:2381               [::]:*                  LISTEN      3501/hpsmhd     
    tcp6       0      0 
    [::]:pop3               [::]:*                  LISTEN      4193/couriertcpd
    tcp6       0      0 
    [::]:imap2              [::]:*                  LISTEN      4163/couriertcpd
    tcp6       0      0 
    [::]:www                [::]:*                  LISTEN      6107/apache2    
    tcp6       0      0 
    [::]:ftp                [::]:*                  LISTEN      6048/proftpd: (acce
    tcp6       0      0 
    [::]:domain             [::]:*                  LISTEN      3392/named      
    tcp6       0      0 
    [::]:ssh                [::]:*                  LISTEN      3409/sshd       
    tcp6       0      0 localhost
    :ipp           [::]:*                  LISTEN      4289/cupsd      
    tcp6       0      0 
    [::]:smtp               [::]:*                  LISTEN      14949/master    
    tcp6       0      0 localhost
    :953           [::]:*                  LISTEN      3392/named      
    tcp6       0      0 
    [::]:https              [::]:*                  LISTEN      6107/apache2    
    tcp6       0      0 
    [::]:2301               [::]:*                  LISTEN      3501/hpsmhd     
    tcp6      26      0 192.168.2.4
    %321357:5900 192.168.2.3%152466:3411 ESTABLISHED 12406/vino-server
    server1
    :~


    can someone point me in the direction of things to check my emails should go to /home/vmail/ directory
     
  2. White

    White Member

    ive done a dig and i have no MX record

    PHP:
    server1:~# dig mx mcahost.com

    ; <<>> DiG 9.6-ESV-R4 <<>> mx mcahost.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>
    HEADER<<- opcodeQUERYstatusNOERRORid53947
    ;; flagsqr rd raQUERY1ANSWER0AUTHORITY1ADDITIONAL0

    ;; QUESTION SECTION:
    ;
    mcahost.com.            IN    MX

    ;; AUTHORITY SECTION:
    mcahost.com.        86400    IN    SOA    ns.hosteurope.comhostmaster.mcahost.com2007102502 86400 3600 1209600 86400

    ;; Query time269 msec
    ;; SERVER192.168.2.1#53(192.168.2.1)
    ;; WHENSun Nov 27 19:23:18 2011
    ;; MSG SIZE  rcvd90
    ok? so what now, how do i create one and where do i put it????
    also i may have to setup my router would this be in the virtual server section of it in the NAT section??
     
    Last edited: Nov 27, 2011
  3. White

    White Member

    Solved

    it was the fact i had not set up my router to direct the mail to my server, setting up the NAT section worked my inboxes are now recieving qued mail HOORAY !!
     

Share This Page