Postfix not delivering Email

Discussion in 'HOWTO-Related Questions' started by Threk, Mar 4, 2009.

  1. Threk

    Threk New Member

    I had a mail server blow up on me last night, Hard drive is completely dead.
    Someone else configured this whole system and the part that died (email storage, IMAP and POP for most of the domains) is the part I knew the least about. I know it was authenticating against our LDAP server, as are the inbound routing server and the outbound SMTP server. So I quickly grabbed the most recent server CD I had handy (Ubuntu 8.10) and installed Postfix, and Dovecot.

    I found some tutorials on LDAP, Postfix and Dovecot and tried to modify them to match our existing LDAP schema (I'd rather not be trying to re-configure the remaining servers.)

    Everything seems to be working now except mail never gets delivered to the mailboxes.

    Here is my /etc/postfix/main.cf

    That server died just before I was going to go to bed last night so I haven't slept in 34 hours or so. I might be missing something obvious, and any help would be appreciated.
     
  2. Threk

    Threk New Member

    libpostfix-global.so.1.0.1 is broken

    I finally though to check syslog and found that every time postfix tries to deliver an email libpostfix-global.so.1.0.1 segfaults.

    just !!#$% wonderfull
     
  3. Threk

    Threk New Member

    I think the segfault is due to a problem in my configuration, I installed OpenBSD on the server and with pretty much the same configuration it gives the same error.

    Any hints/ideas would be VERY welcome
     
  4. falko

    falko Super Moderator ISPConfig Developer

    In this case it seems to be a hardware problem...
    Have you tried memtest to check the RAM?
     
  5. Threk

    Threk New Member

    Actually it was the configuration

    uid=%n works in dovecot, but not postfix
     

Share This Page