Postfix not binding to port 25

Discussion in 'Installation/Configuration' started by jasonwashere, Aug 5, 2008.

  1. jasonwashere

    jasonwashere New Member

    Hello all,
    having an issue where Postfix is not binding to port 25 from the get go, so I can't even send the first email to get ride of the chdir errors.
    I have looked everywhere I know where to and can't see anything that is wrong. Using the http://howtoforge.com/virtual-users-and-domains-postfix-courier-mysql-fedora8 tutorial. firewall and SElinux disabled of course.

    Netstat as you can see nothing on 25
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 *:54374                     *:*                         LISTEN      1612/rpc.statd
    tcp        0      0 localhost.localdomain:10024 *:*                         LISTEN      1934/amavisd (maste
    tcp        0      0 localhost.localdomain:10025 *:*                         LISTEN      2408/master
    tcp        0      0 *:mysql                     *:*                         LISTEN      1904/mysqld
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      1593/rpcbind
    tcp        0      0 *:ndmp                      *:*                         LISTEN      2236/perl
    tcp        0      0 192.168.1.205:domain        *:*                         LISTEN      1740/named
    tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN      2157/cupsd
    tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      1740/named
    tcp        0      0 *:imaps                     *:*                         LISTEN      1952/couriertcpd
    tcp        0      0 *:pop3s                     *:*                         LISTEN      1964/couriertcpd
    tcp        0      0 *:pop3                      *:*                         LISTEN      1958/couriertcpd
    tcp        0      0 *:imap                      *:*                         LISTEN      1945/couriertcpd
    tcp        0      0 *:http                      *:*                         LISTEN      2036/httpd
    tcp        0      0 *:ssh                       *:*                         LISTEN      1816/sshd
    tcp        0      0 localhost6.localdomain:rndc *:*                         LISTEN      1740/named
    tcp        0      0 *:https                     *:*                         LISTEN      2036/httpd
    tcp        0      0 ::ffff:192.168.1.205:ssh    ::ffff:192.1:tclprodebugger ESTABLISHED 2279/0
    
    Main CF

    Code:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    mydestination = dragon.codepanzyz.com, localhost, localhost.localdomain
    #mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 5
    debugger_command =
             PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
             xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.4.5/samples
    readme_directory = /usr/share/doc/postfix-2.4.5/README_FILES
    myhostname = dragon.codepanzyz.com
    mynetworks = 127.0.0.0/8, 192.168.1.0/24
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    smtpd_use_tls = yes
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_create_maildirsize = yes
    virtual_mailbox_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recip\
    ient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_\
    maps
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    
    Maillog fresh after a reboot showing postfix starting fine, I can restart/reload it as well, same goes for clamd.amavisd & amavisd with the exception of "Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan" showing up.
    Code:
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .gz   at /usr/bin/gzip -d
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .bz2  at /usr/bin/bzip2 -d
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .lzo  at /usr/bin/lzop -d
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .rpm  at /usr/bin/rpm2cpio
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .cpio at /usr/bin/pax
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .tar  at /usr/bin/pax
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .deb  at /usr/bin/ar
    Aug  5 01:34:21 dragon amavis[1934]: Internal decoder for .zip
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .7z   at /usr/bin/7za
    Aug  5 01:34:21 dragon amavis[1934]: No decoder for       .rar  tried: rar, unrar
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .arj  at /usr/bin/arj
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .arc  at /usr/bin/nomarch
    Aug  5 01:34:21 dragon amavis[1934]: No decoder for       .zoo  tried: zoo, unzoo
    Aug  5 01:34:21 dragon amavis[1934]: No decoder for       .lha  tried: lha
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .cab  at /usr/bin/cabextract
    Aug  5 01:34:21 dragon amavis[1934]: No decoder for       .tnef tried: tnef
    Aug  5 01:34:21 dragon amavis[1934]: Internal decoder for .tnef
    Aug  5 01:34:21 dragon amavis[1934]: Found decoder for    .exe  at /usr/bin/arj
    Aug  5 01:34:21 dragon amavis[1934]: Using primary internal av scanner code for ClamAV-clamd
    Aug  5 01:34:21 dragon amavis[1934]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
    Aug  5 01:34:22 dragon amavis[1934]: Creating db in /var/spool/amavisd/db/; BerkeleyDB 0.32, libdb 4.5
    Aug  5 01:34:22 dragon clamd[1926]: Loaded 385536 signatures.
    Aug  5 01:34:22 dragon clamd[1926]: Unix socket file /var/spool/amavisd/clamd.sock
    Aug  5 01:34:22 dragon clamd[1926]: Setting connection queue length to 15
    Aug  5 01:34:22 dragon clamd[1926]: Archive: Archived file size limit set to 10485760 bytes.
    Aug  5 01:34:22 dragon clamd[1926]: Archive: Recursion level limit set to 8.
    Aug  5 01:34:22 dragon clamd[1926]: Archive: Files limit set to 1000.
    Aug  5 01:34:22 dragon clamd[1926]: Archive: Compression ratio limit set to 250.
    Aug  5 01:34:22 dragon clamd[1926]: Archive support enabled.
    Aug  5 01:34:22 dragon clamd[1926]: Algorithmic detection enabled.
    Aug  5 01:34:22 dragon clamd[1926]: Portable Executable support enabled.
    Aug  5 01:34:22 dragon clamd[1926]: ELF support enabled.
    Aug  5 01:34:22 dragon clamd[1926]: Mail files support enabled.
    Aug  5 01:34:22 dragon clamd[1926]: Mail: Recursion level limit set to 64.
    Aug  5 01:34:22 dragon clamd[1926]: OLE2 support enabled.
    Aug  5 01:34:22 dragon clamd[1926]: PDF support disabled.
    Aug  5 01:34:22 dragon clamd[1926]: HTML support enabled.
    Aug  5 01:34:22 dragon clamd[1926]: Self checking every 1800 seconds.
    Aug  5 01:34:22 dragon sendmail[1972]: alias database /etc/aliases rebuilt by root
    Aug  5 01:34:22 dragon sendmail[1972]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
    Aug  5 01:34:23 dragon postfix/postfix-script[2017]: starting the Postfix mail system
    Aug  5 01:34:23 dragon postfix/master[2018]: daemon started -- version 2.4.5, configuration /etc/postfix
    
    The master.cf
    Code:
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #smtps     inet  n       -       n       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #628      inet  n       -       n       -       -       qmqpd
    pickup    fifo  n       -       n       60      1       pickup
    cleanup   unix  n       -       n       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       n       300     1       oqmgr
    tlsmgr    unix  -       -       n       1000?   1       tlsmgr
    rewrite   unix  -       -       n       -       -       trivial-rewrite
    bounce    unix  -       -       n       -       0       bounce
    defer     unix  -       -       n       -       0       bounce
    trace     unix  -       -       n       -       0       bounce
    verify    unix  -       -       n       -       1       verify
    flush     unix  n       -       n       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp      unix  -       -       n       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       n       -       -       smtp
            -o fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       n       -       -       showq
    error     unix  -       -       n       -       -       error
    retry     unix  -       -       n       -       -       error
    discard   unix  -       -       n       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       n       -       -       lmtp
    anvil     unix  -       -       n       -       1       anvil
    scache    unix  -       -       n       -       1       scache
    amavis    unix  -       -       -       -       2       smtp
            -o smtp_data_done_timeout=1200
            -o smtp_send_xforward_command=yes
    
    127.0.0.1:10025 inet n - - - - smtpd
            -o content_filter=
            -o local_recipient_maps=
            -o relay_recipient_maps=
            -o smtpd_restriction_classes=
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=
            -o smtpd_recipient_restrictions=permit_mynetworks,reject
            -o mynetworks=127.0.0.0/8, 192.168.1.1/24
            -o strict_rfc821_envelopes=yes
            -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
            -o smtpd_bind_address=127.0.0.1
    
    Anyone sees something wrong in here or can point me in the right direction it would be a lot better then reformatting for the 3rd time this now coming up on 45 hours day.

    Thanks & Cheers...
     
  2. Hans

    Hans Moderator ISPConfig Developer

  3. jasonwashere

    jasonwashere New Member

    I'm not to sure what you mean by that reply, there is noting on that page of the tutorial to add to the main.cf, just the commands
    postconf -e 'content_filter = amavis:[127.0.0.1]:10024'
    postconf -e 'receive_override_options = no_address_mappings'
    which as you can see by looking at my post is in the main.cf.
    If you meant the afterward add ... and the stuff for the master.cf as you can see by my post that it is in there as well.
     
  4. Hans

    Hans Moderator ISPConfig Developer

    I mean this part below, i don't see all those lines within your /etc/postfix/main.cf:

    ---

    Afterwards append the following lines to /etc/postfix/master.cf:

    [...]
    amavis unix - - - - 2 smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes

    127.0.0.1:10025 inet n - - - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    -o smtpd_bind_address=127.0.0.1
     
  5. ralic

    ralic New Member

    Is that your whole master.cf file?
    It seems to be missing this critical line at the top:
    Code:
    smtp      inet  n       -       -       -       -       smtpd
    
     
  6. jasonwashere

    jasonwashere New Member

    Thats it

    That is it, always love how one line in one file can bring a system to a halt.

    Thanks for the help.
     

Share This Page