Postfix not accepting [email protected] but is accepting [email protected]

Discussion in 'Installation/Configuration' started by maberglund, Oct 7, 2010.

  1. maberglund

    maberglund New Member

    Hello all!

    I have postfix/ispconfig 3/centos/etc. seemingly properly configured but I am running into a problem.

    I have setup an email account in the system, [email protected]

    I have properly set up my dns such that I have and A record for and

    with an mx record for

    So, I expect that any mail that goes to [email protected] would be forwarded to (which are on the same machine), but instead postfix returns a 550 response and kicks the email back.

    Do I have to set up another email domain in ispconfig and do an alias on each user, or is there a more global way to do this? I explored the $mydestination variable in postfixs, but from my reading, it appears that the right way to adjust these sort of things on ispconfig 3 with mysql is through the ispconfig interface itself

    Any help would be appreciated!
  2. falko

    falko Super Moderator ISPConfig Developer

    You have to create as a mail domain in ISPConfig and then create an alias.
  3. maberglund

    maberglund New Member

    Thanks falko. So, after much fiddling, the only way I got this to work was to create two domains. One and the other

    Then I could make one ( and alias of the other (

    Is this correct? Is seems very counterintuitive.
  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, this is correct (if you want to alias all email accounts of to

Share This Page