Postfix+MySql running on a non default port

Discussion in 'Installation/Configuration' started by PToN, Oct 23, 2006.

  1. PToN

    PToN New Member

    Hello,

    i have set up server1 with Postfix+MySQL+Courier+TLS on RHEL4 and everything works five, but recently i was asked to add a server2 that doesnt requiere any authentication from local users and it must be on port 25..

    So the server2 is installed and it runs sendmail; all the needed local pcs are able to send mail with no problems...

    But on my nice setup on server1 connections get rejected. I changed the port from 25 to 125 and i am able to send emails with no problems, but i cant receive any mail. If i check the logs i see no attempts of connection on server1, but if i go to a server3 and send mail from it i see the following line:
    So my question is: How cant i get this tutorial (http://www.howtoforge.com/virtual_postfix_mysql_quota_courier) to work on a port other than 25...? I check the router and firewall and none of them are blocking the port, also if i go to a remote computer and "telnet server1.myhouse.com 125" it works, it iw able to connect with no problems.. but again, if i send email from a remotedomain to myhouse.com the connection get refused...

    Any ideas..?

    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. PToN

    PToN New Member

    On that tutorial the part that says to modify /etc/pam.d/smtpd.conf, if i change that to pam_krb5.so and make it authenticate against my AD right...?

    has anyone tried that...?

    Thanks
     

Share This Page