postfix+ mysql and /var/spool/postfix problem

Discussion in 'Installation/Configuration' started by asymetrixs, Dec 20, 2007.

  1. asymetrixs

    asymetrixs New Member


    first of all i used the follwing howto for my mailserver which did a really good job (using etch and postfix and so on...):

    but i wondered about my mailserver, because it didn't send my system mails anymore since i configured postfix to use mysql for user and quota administration and to send the mails to an external address (my home address and not to the an system user in the debian system)

    all system mails sent by the system itself or the administrator are stored in /var/spool/postfix, but this directory isn't mentioned in the actual config of postfix.

    # See /usr/share/postfix/ for a commented, more complete version
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    myhostname = **masked**
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = localhost, localhost.localdomain
    relayhost =
    mynetworks =
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/, mysql:/etc/postfix/
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/
    virtual_mailbox_base = /var/spool/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    transport_maps = proxy:mysql:/etc/postfix/
    virtual_create_maildirsize = yes
    virtual_mailbox_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_reci$
    content_filter = amavis:[]:10024
    receive_override_options = no_address_mappings
    and the /var/log/mail.err gives me the following:
    postfix/postqueue[11574]: fatal: Queue report unavailable - mail system is down
    so i think, that the following line is missing in the
    queue_directory = /var/spool/postfix
    but if i add this line and restart postfix, it has no influence on the behaviour of the mailsystem.

    the mailsystem itself works great with the user and quota settings stored in the mysql tables, but the system mailqueue seems to be ignored.

    can someone help me please?

    thank you all.
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any other errors in your mail log?

    You can check the settings that you see in the output of
    postconf -d
    These are the default settings that are unless something else is specified in /etc/postfix/

    If you want to forward system emails to an external email account, you can modify /etc/aliases, e.g.:
    root: [email protected]
    afterwards and restart Postfix.

Share This Page