Postfix - masquerade not working

Discussion in 'Server Operation' started by phreak, Nov 30, 2006.

  1. phreak

    phreak New Member

    I know the setup is simple but for some reason its not working on my systems. I can send email to external locations and its sent without a problem but the source address is coming up as user@host.mydomain.com instead of user@mydomain.com.

    I am running centos 4 with postfix 2.2.10. I have set up the following in main.cf:

    myhostname = host.mydomain.com
    mydomain = mydomain.com
    myorigin = $myhostname
    masquerade_domains = $mydomain

    Has anyone else ran into this same problem or does anyone have any suggestions?

    TIA!!
     
  2. phreak

    phreak New Member

    I also checked the logs and when mail is sent it shows as being sent from user@host.mydomain.com.

    Everything else in the logs look ok.

    Thanks!

    (I can provide the full my.cnf if necessary)
     
    Last edited: Nov 30, 2006
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You must set the correct email address in your email client.
     
  4. phreak

    phreak New Member

    how do you set up the mail client? its that the point of setting up masquerading??
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  6. phreak

    phreak New Member

    i am not using a windows client. i am sending mail from the command line on the same linux server that i am running postfix
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Then you must specify the sender address on the command line. You can read the man page for the command you use.
     

Share This Page