postfix main.cf

Discussion in 'Server Operation' started by mishko, Nov 10, 2006.

  1. mishko

    mishko New Member

    Can anyone have a look on my postfix main.cf ? When I try to send or recieve mail from ispconfig webmail tool everything looks good when I send some mail it show me that the mail was send succesfull but no mail is coming out the same is for recieving i try to mail to it no errors has been shown on outlook or other mailclients but can`t recieve any of it :-(((

    maybe I`m totaly blind if I can`t see any error in my main.cf



    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    myhostname = domain.com
    mydomain = localhost.domain.com

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
    smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key

    smtpd_use_tls=yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = server1.domain.com, localhost.domain.com, , localhost
    relayhost = $mydestination
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    #inet_interfaces = localhost
    #inet_interfaces = $myhostname
    #inet_interfaces = $myhostname, localhost
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    stmpd_tls_auth_only = no
    stmpd_use_tls = yes
    stmp_use_tls = yes
    stmp_tls_note_starttls_offer = yes
    stmpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    stmpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    stmpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    stmpd_tls_loglevel = 1
    stmpd_tls_received_headers = yes
    stmpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names

    local_recipient_maps =
    mail_name =
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log? What's the output of
    Code:
    postcheck
    ?
     
  3. mishko

    mishko New Member

    so mail.log is like this

    Nov 13 09:01:20 server1 postfix/smtpd[21036]: connect from myhosting.myhosting.com[x.x.x.x]
    Nov 13 09:01:21 server1 postfix/smtpd[21036]: 1204448031C: client=myhosting.myhosting.com[x.x.x.x]
    Nov 13 09:01:21 server1 postfix/cleanup[21039]: 1204448031C: message-id=<[email protected]>
    Nov 13 09:01:21 server1 postfix/qmgr[13423]: 1204448031C: from=<[email protected]>, size=2005, nrcpt=1 (queue active)
    Nov 13 09:01:21 server1 postfix/smtpd[21036]: disconnect from myhosting.myhosting.com[x.x.x.x]
    Nov 13 09:01:21 server1 postfix/local[21040]: 1204448031C: to=<[email protected]>, relay=local, delay=0, status=bounced (unknown user: "postfixmail")
    Nov 13 09:01:21 server1 postfix/cleanup[21039]: 3612A48039C: message-id=<[email protected]>
    Nov 13 09:01:21 server1 postfix/qmgr[13423]: 3612A48039C: from=<>, size=3638, nrcpt=1 (queue active)
    Nov 13 09:01:21 server1 postfix/qmgr[13423]: 1204448031C: removed
    Nov 13 09:01:21 server1 postfix/smtp[21042]: fatal: valid hostname or network address required in SMTP server description: /etc/postfix/local-host-names
    Nov 13 09:01:22 server1 postfix/qmgr[13423]: warning: premature end-of-input on private/smtp socket while reading input attribute name
    Nov 13 09:01:22 server1 postfix/qmgr[13423]: warning: private/smtp socket: malformed response
    Nov 13 09:01:22 server1 postfix/master[13421]: warning: process /usr/lib/postfix/smtp pid 21042 exit status 1
    Nov 13 09:01:22 server1 postfix/qmgr[13423]: warning: transport smtp failure -- see a previous warning/fatal/panic logfile record for the problem description
    Nov 13 09:01:22 server1 postfix/master[13421]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling
    Nov 13 09:01:22 server1 postfix/qmgr[13423]: 3612A48039C: to=<[email protected]>, relay=none, delay=1, status=deferred (delivery temporarily suspended: unknown mail transport error)


    I don`t have postcheck so I can`t do it
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/local-host-names?

    I'm sorry, the correct command is
    Code:
    postfix check
     
  5. mishko

    mishko New Member

    /etc/postfix/local-host-names

    localhost
    server1.mydomain.com
    localhost.server1.mydomain.com
    localhost.mydomain.com
    www.mydomain.com
    mydomain.com
    mail.mydomain.com

    command postfix check run without errors nothing displayed

    PS> I thing this site could wear name falkoforge.com cause in every thread I`ve readed it was you who solved the problem I wonder how can you answer to all these unstopable stupid questions :))))))) we love you FALKO
     
  6. falko

    falko Super Moderator ISPConfig Developer

    That looks ok. Please remove
    Code:
    mydestination = server1.domain.com, localhost.domain.com, , localhost
    from /etc/postfix/main.cf and restart Postfix. Do you still see errors in the mail log then?
     
  7. mishko

    mishko New Member

    Hey I`ve reinstalled my server now everything seems to bee going well except one thing I`ve made one new user in ispconfig with mail: [email protected], username: web1_mishko, and pass...

    this mail is working fine no problem with sending or recieving but when I send mail to someone he`ll see mail address in this format [email protected] he can reply to this address successfull but I whant the address in this format [email protected] where can I switch to don`t show username but email address in the mail?
     
  8. falko

    falko Super Moderator ISPConfig Developer

  9. mishko

    mishko New Member

    of course I`m such an idiot shame on me ;-))))) sorry for feeding you with my stupid questions :)))))
     

Share This Page