postfix/maildrop problem

Discussion in 'Installation/Configuration' started by servidorv, Jul 18, 2012.

  1. servidorv

    servidorv New Member

    Hi, and thanks for your forums, but i have a problem.
    the problem is that i installed ispconfig 3.0.4.6 on a linode server with debian 6, i followed the linode tutorials, and everything is ok, ecept for the receiving emails, i can send emails but not receive them. in my mail queue it says:

    HTML:
    89F3D14185 2593 Wed Jul 18 10:58:19 [email protected]
    (temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/experienciaeducativa.com/servidorv/3047.0.li477-95.)
    [email protected]
    in my mail warn log it says:

    HTML:
    Jul 18 10:17:04 li477-95 amavis[2090]: (02090-01) (!)run_av (ClamAV-clamd) FAILED - unexpected , output="/var/lib/amavis/tmp/amavis-20120718T101703-02090/parts: lstat() failed: Permission denied. ERROR\n"
    Jul 18 10:17:04 li477-95 amavis[2090]: (02090-01) (!)ClamAV-clamd av-scanner FAILED: CODE(0xa8243d8) unexpected , output="/var/lib/amavis/tmp/amavis-20120718T101703-02090/parts: lstat() failed: Permission denied. ERROR\n" at (eval 105) line 594.
    in my mail log it says:

    HTML:
    Jul 18 11:44:37 (none) postfix/pipe[3246]: E0B2C14181: to=, relay=maildrop, delay=70018, delays=70018/0.09/0/0.02, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/experienciaeducativa.com/servidorv/3248.0.li477-95. )
    i dont know what seems to be the problem, i dont know if it is because clamav has a problem or if they are two separated problems.
    can someone please help, im going crazy with these sisnce 2 days ago. i keep looking in google for answers but no go.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I expect that tehse are two separate problems. Please login to ispconfig and check the jobqueue in the monitor module, are there any pending jobs listed?

    Then post the output of:

    ls -la /var/vmail/experienciaeducativa.com/servidorv/

    And di you get any errors during ispconfig installation?
     
  3. servidorv

    servidorv New Member

    first thanks for your help,

    in the jobqueue there is nothing
    and the

    [email protected]:~# ls -la /var/vmail/experienciaeducativa.com/servidorv/
    ls: cannot access /var/vmail/experienciaeducativa.com/servidorv/: No such file or directory

    and no problem in the instalation
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok,please post the output of:

    ls -la /var/vmail/

    Did you create a email account in ispconfig with the address "[email protected]"?

    and post the output of thes ecommands:

    grep experienciaeducativa.com /etc/postfix/main.cf
    cat /etc/mailname
     
  5. servidorv

    servidorv New Member

    HTML:
    [email protected]:~# ls -la /var/vmail/
    total 32
    drwxr-xr-x  4 vmail vmail 4096 Jul 17 11:38 .
    drwxr-xr-x 17 root  root  4096 Jul 18 00:30 ..
    -rw-r--r--  1 vmail vmail  220 Apr 10  2010 .bash_logout
    -rw-r--r--  1 vmail vmail 3184 Apr 10  2010 .bashrc
    drwx------  2 vmail vmail 4096 Jul 17 14:48 experienciaeducativa.com
    -rw-------  1 vmail vmail 1454 Jul 17 10:59 .mailfilter
    drwxr-xr-x  3 vmail vmail 4096 Jul 17 11:38 mailfilters
    -rw-r--r--  1 vmail vmail  675 Apr 10  2010 .profile
    i've created the mail in ispconfig and

    grep experienciaeducativa.com /etc/postfix/main.cf
    nothing comes out

    [email protected]:~# cat /etc/mailname
    debian
     
  6. servidorv

    servidorv New Member

    can anyone answer please, im frustrated to this problem. :(
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Can you send a test mail to [email protected] and check if there are any errors in /var/log/mail.log at the same time?
     
  8. Sir Henry

    Sir Henry Member

Share This Page