Postfix - Mail bounce

Discussion in 'HOWTO-Related Questions' started by russel_sc, Jul 26, 2011.

  1. russel_sc

    russel_sc New Member

    Hi All.

    It's highly appreciated if someone can tell me a solution for my below problem: -


    I have a postfix mail server on ubuntu 10.04 lts behind a router. so all local users are fetching/sending mails through ms outlook using local IP. Sometimes when internet goes down and any mail send then it bounced back immediately saying domain not found. Can u please tell me how i configure to hold all mails in postfix server rather than bounce when internet fails and will pass through when restored the internet around 15-30 minutes?

    Thank u.


    Regards,
    Russel.
     
  2. dipeshmehta

    dipeshmehta New Member

    Check your postfix's main.cf for bounce_queue_lifetime parameter, if it is set to 0 then delivery attempts tried only once. (It is 5 days by default).
     
  3. russel_sc

    russel_sc New Member

    There is no any "bounce_queue_lifetime" parameter but smtpd_error_sleep_time = 0. Please tell if the "smtpd_error_sleep_time" is causing the problem or not?

    Regards,
    Russel
     
  4. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Did you google for the given keywords / configuration parameters?

    Then you'd have come across: http://www.postfix.org/postconf.5.html

    So this is the reason, both of these switches CAN be explicitly set in your main.cf. But if not set, then the default value is used.

    According to the above documentation, I'd say changing smtpd_error_sleep_time back to 1 (default) won't help here.

    Maybe it helps to see your main.cf and the exact error message from the logs. As for my understanding "bounce_queue_lifetime" (which is set to 5d by default) should work for this, as the message is kept for 5 days until it gets back to the original sender.
     

Share This Page