Postfix Loops Back error and weird email headers

Discussion in 'General' started by reimagine, Jul 26, 2006.

  1. reimagine

    reimagine New Member

    I'm getting the "loops back" error on my new ISPConfig setup (running on CentOS). Sometimes emails go through properly, other times I receive the following error message. In this example, email was sent to [email protected].

    This is the Postfix program at host

    I'm sorry to have to inform you that your message could not be
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <[email protected]> (expanded from < [email protected]>): mail for loops back to myself​

    The headers of emails that make it through also display multiple domains. For example:

    X-Original-To: [email protected]
    Delivered-To: [email protected]
    Received: from ( []) by (Postfix) with ESMTP id B7AEBF6045A for <[email protected]>; Wed, 26 Jul 2006 10:49:41 -0400 (EDT)​

    Any ideas of where to look as I try to fix this? It seems that the file for Postfix is set up properly:
    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names​
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add:

    (the domain that is mentioned in the error message)

    at the end of the file:

  3. reimagine

    reimagine New Member

    Trying that...

    Thanks for the info. I looked at the site settings. was a co-domain on another site. I had a www version setup (so was listed in local-host-names), but no non-www version (so was not listed there). I went ahead and set up (no www) as a co-domain and it's now showing up it the local-host-names file. I did a postfix reload and I'll keep an eye out for any more errors.

    How should I set up co-domains if they aren't going to be used for email. My only options are local mail server or external mail server ... there is no "none" option.

  4. reimagine

    reimagine New Member

    variation on the error

    Here is another example of a "loops back" error that I'm getting, but with a slight variation:

    Jul 27 20:54:53 ns1 postfix/smtp[19638]: E3C74F604AA: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=7053, status=SOFTBOUNCE (mail for loops back to myself)​

    "domain1" is the same name in both instances, but somehow "mail" gets added to the beginning of the domain name. There are no listed in the local-host-names file.

    The DNS settings for this domain are as follows:
    A Record www mail

    Mailserver @​

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add to the local-host-names file too.

Share This Page