Postfix local-host-names ?

Discussion in 'Installation/Configuration' started by Herbert, May 6, 2006.

  1. Herbert

    Herbert New Member

    My SMTP server work not corectly..
    example:
    When i send a mail to test@domain.tld then the mail wil send it to test without @domain.tld
    I'm looking in local-host-names and the domains are not correct?
    the beginning: (test.nl = hostname)
    localhost
    test.nl
    localhost.test.nl
    localhost.nl
    www.domain1.nl
    www.domain2.nl
    etc.. etc..
    domain1.nl
    domain2.nl

    I think the www. is not good? in sendmail is only domain without www.

    I will use my own smtp server what i doing wrong??
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You must add a Co-Domain (domain1.nl, domain2.nl) with an empty hostname to that web site in ISPConfig.
     
  3. Herbert

    Herbert New Member

    Hello Falko,
    The co-domains exists already before i post in this thread.
    In my aliasses the first lines begins with www.domain.tld
    the last lines with out www (domain.tld)
    Every domain is 2 times in the aliasses, with www and witout www
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That is correct.
     
  5. Herbert

    Herbert New Member

    Thanks till,
    but i'm just confused why my smtp not working?
    When i use my own smtp server the mailer say's sucessfull delevery to ...
    and te receiver se no mail.
    The smtp work to local adresses ok
    i'm just thinking a'am behaind a NAT with IP: 10.0.0.151
    When i use local pop3 then i have to give this IP for pop3
    Maby i have to do something in the config for my smtp ?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Where are you sending to? Big freemail providers like Hotmail block emails that originate from dynamic IP addresses. And often you need a correct SPF record for your domains.
     
  7. Herbert

    Herbert New Member

    Falko i'am working before with sendmail and i had never problems with smtp.
    Sinds i use ispconfig and postfix i can't use my smtp server.
    I have a static IP adres, its my own.
    The problem is still there..
     
  8. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when you try to send an email?
     
  9. Herbert

    Herbert New Member

    Hello Falko,
    sorry i was not home..
    This in my log:
    -
    May 10 09:07:39 hmnet sendmail[4040]: k4A77d9j004040: from=postfix@hmnet.nl, size=388, class=0, nrcpts=1, msgid=<1147244859.4036@hmnet.nl>, relay=root@localhost
    May 10 09:07:40 hmnet postfix/smtpd[4043]: connect from localhost.localdomain[127.0.0.1]
    May 10 09:07:40 hmnet postfix/smtpd[4043]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    May 10 09:07:40 hmnet sendmail[4040]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    May 10 09:07:40 hmnet postfix/smtpd[4043]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    May 10 09:07:40 hmnet postfix/smtpd[4043]: 3E710146C3F: client=localhost.localdomain[127.0.0.1], sasl_sender=postfix@hmnet.nl
    May 10 09:07:40 hmnet postfix/cleanup[4046]: 3E710146C3F: message-id=<1147244859.4036@hmnet.nl>
    May 10 09:07:40 hmnet sendmail[4040]: k4A77d9j004040: to=herbert@zonnet.nl, ctladdr=postfix@hmnet.nl (89/89), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=30388, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 3E710146C3F)
    May 10 09:07:40 hmnet postfix/smtpd[4043]: disconnect from localhost.localdomain[127.0.0.1]
    May 10 09:07:40 hmnet postfix/qmgr[3959]: 3E710146C3F: from=<postfix@hmnet.nl>, size=839, nrcpt=1 (queue active)
     
  10. falko

    falko Super Moderator ISPConfig Developer

    I don't see any errors here. Maybe you can post a longer excerpt from your mail log?
     
  11. Herbert

    Herbert New Member

    Falko here the same i don't see errors..
    Only this:
    mail.zonnet.nl has address 62.58.50.9
    My MTA connect to 62.58.50.202 thats wrong, then i get time out..
    I know its not the problem from ispconfig but from postfix here.
     
  12. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/hosts and /etc/resolv.conf?
     
  13. Herbert

    Herbert New Member

    Falko i'm behaind a speedtouch 546i
    My server get local IP 10.0.0.151 from DHCP

    ; generated by /sbin/dhclient-script
    search lan
    nameserver 10.0.0.138
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Please make sure you forward port 25 from your router to your ISPConfig system.
     
  15. Herbert

    Herbert New Member

    Falko the problem is over now, i used the DHCP server from the Speedtouch modem and i get a wrong nameserver.
    I give my server a static IP and i configure the nameservers manual, everything works now.
    Many thanks,
    Herbert
     

Share This Page