Postfix local delivery probmlem

Discussion in 'Server Operation' started by Vcepelin, Feb 18, 2009.

  1. Vcepelin

    Vcepelin New Member

    hi everyone i have a problem with my postfix loacl delivery
    im trying to send mail to other user on my linux machine using sendmail
    from root to Vaskata
    im new in mail servers so im posting the postfix main.cf and mail logs
    -------------main.cf--------------
    readme_directory = /usr/share/doc/packages/postfix/README_FILES
    inet_protocols = all
    biff = no
    mail_spool_directory = /var/mail
    canonical_maps = hash:/etc/postfix/canonical
    virtual_alias_maps = hash:/etc/postfix/virtual
    virtual_alias_domains = hash:/etc/postfix/virtual
    relocated_maps = hash:/etc/postfix/relocated
    transport_maps = hash:/etc/postfix/transport
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    masquerade_exceptions = root
    masquerade_classes = envelope_sender, header_sender, header_recipient
    myhostname = linux.site
    program_directory = /usr/lib/postfix
    masquerade_domains =
    mydestination = $linux.site, localhost.$infi.com #infi.com
    defer_transports =
    disable_dns_lookups = no
    home_mailbox = Mailbox
    mailbox_command =
    mailbox_transport =
    strict_8bitmime = no
    disable_mime_output_conversion = no
    smtpd_sender_restrictions = hash:/etc/postfix/access
    smtpd_helo_required = no
    smtpd_helo_restrictions =
    strict_rfc821_envelopes = no
    smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
    smtp_sasl_auth_enable = no
    smtpd_sasl_auth_enable = no
    smtpd_use_tls = no
    smtp_use_tls = no
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000
    #myorigin = $infi.com
    mynetworks = 192.168.0.0/24, 127.0.0.0/8
    #mail_owner = Vaskata
    #mydestination = $infi.com, localhost.$infi.com $infi.com
    #local_transport = virtual
    mydomain = infi.com

    ------------mail-log----------
    Feb 18 10:08:27 linux postfix/pickup[19610]: 85FA71A804B: uid=0 from=<root>
    Feb 18 10:08:27 linux postfix/cleanup[21281]: 85FA71A804B: message-id=<[email protected]>
    Feb 18 10:08:27 linux postfix/qmgr[20619]: 85FA71A804B: from=<[email protected]>, size=276, nrcpt=2 (queue active)
    Feb 18 10:08:29 linux postfix/smtp[21283]: 85FA71A804B: to=<[email protected]>, relay=mail.global.frontbridge.com[216.32.181.22]:25, delay=5, delays=2.7/0.02/1.9/0.44, dsn=2.0.0, status=sent (250 Ok: queued as 99AAD14C805C)
    Feb 18 10:08:29 linux postfix/smtp[21283]: 85FA71A804B: to=<[email protected]>, relay=mail.global.frontbridge.com[216.32.181.22]:25, delay=5, delays=2.7/0.02/1.9/0.44, dsn=2.0.0, status=sent (250 Ok: queued as 99AAD14C805C)
    Feb 18 10:08:29 linux postfix/qmgr[20619]: 85FA71A804B: removed
    help me plss
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    infi.com needs to be in your mydestination
     
  3. Vcepelin

    Vcepelin New Member

    10x but that really didn't help me ..
     
  4. topdog

    topdog Active Member HowtoForge Supporter

    could be because you have mydestination specified twice.
     

Share This Page