Postfix load balancing

Discussion in 'Server Operation' started by tekzone, Oct 1, 2008.

  1. tekzone

    tekzone New Member


    I am trying to setup a load balanced postfix cluster. Nothing extravagant. Multiple postfix servers will be used and their data/mysql will be stored on a separate NAS. I have already setup the NAS and MySQL which is pretty simple...

    I setup the load balancing node following the tutorial available on this site for Apache clusters. I did modify ldirectord so that it would use SMTP.

    My problem is that postfix doesn't answer to the SMTP queries coming from the load balancer. Queries coming directly to it are answered fine and for that matter, the server is in production.

    Here is an extract from my

    myhostname =
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination =,, , localhost
    relayhost =
    mynetworks =,
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    relay_domains =
    proxy_interfaces =

    Has anyone gotten this to work ? I should be making a tutorial after I get this to work.

    Thank you in advance,

  2. falko

    falko Super Moderator ISPConfig Developer

    What's in the mail log when the load balancer makes an SMTP query?
  3. tekzone

    tekzone New Member

    Nothing. Postfix doesn't even see it I think. A tcpdump shows that the request arrives to the machine. I think postfix just doesn't listen to it.

  4. falko

    falko Super Moderator ISPConfig Developer

    What's the tcpdump output, and what are the outputs of
    netstat -tap

Share This Page