postfix issues

Discussion in 'Installation/Configuration' started by whitty, Jun 9, 2006.

  1. whitty

    whitty New Member

    For a while during my tweaking/learning phase of installation, I couldn't get email to work at all, then I hammered out the issue and got it working 100% but another one popped up and my solution broke postfix again, and now I can't get postfix to recieve incoming mail anymore. Through some trial-and error analysis and log/config snooping, i've figured out that everything is perfect, but during the phase when i COULD send AND recieve email, the server hello line was the hostname of my server instead of its reverse dns entry (note, not the hostname which was being used for mail, a different one that always resolved). This should help: http://pingability.com/zoneinfo.jsp?domain=whittyhost.us.to Very helpful for domain troubleshooting. I've tried everything I can think of, making sure absolutely every dns entry is super clean and the like, making sure the users are set up, and when it still wouldnt work I looked at the postfix log in /var/log/maillog. What I saw was odd. Hopefully you can help me figure it out (note my current email account on the server is admin.@.whittyhost.us.to, other entries in the log are gmail resending faild emails from a while ago, and galexyalex.@.gmail.com (minus the dots) is the email it's sending from.

    Code:
    Jun  8 23:19:18 www postfix/smtpd[4810]: connect from wr-out-0506.google.com[64.233.184.238]
    Jun  8 23:19:19 www postfix/smtpd[4810]: 2E29C2B7649: client=wr-out-0506.google.com[ 64.233.184.238]
    Jun  8 23:19:19 www postfix/cleanup[4817]: 2E29C2B7649: message-id=<[email protected] >
    Jun  8 23:19:19 www postfix/qmgr[4801]: 2E29C2B7649: from=<[email protected]>, size=1593, nrcpt=1 (queue active)
    Jun  8 23:19:19 www postfix/smtp[4818]: connect to cpe-69-207-240-89.maine.res.rr.com[69.207.240.89]: Connection refused (port 25)
    Jun  8 23:19:19 www postfix/smtp[4818]: 2E29C2B7649: to=< [email protected]>, orig_to=<[email protected]>, relay=none, delay=0, status=deferred (connect to cpe-69-207-240-89.maine.res.rr.com [69.207.240.89]: Connection refused) 
    
    Thanks for the help, let me know if you need anything else in the way of configs/logs!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post your postfix main.cf. If it is too long, you can attach it as .txt file.

    What is in your /etc/hostname file?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Please make sure your ISP doesn't block port 25.
     
  4. whitty

    whitty New Member

    maybe that's the problem - nothing in hostname :) i'll play with that, hadn't noticed. Thanks! In case not, here's main.cf

    and no, port 25 is fine since mail worked in the past. My ISP is great besides the slowish speed, they don't block/shape/filter anything whatsoever (besides maybe a 5 IP cap that I haven't hit yet)and I doubt you could do anything to get banned short of maybe trippling your bandwidth with an uncapped modem or something.

    EDIT: Nope, adding the right host did take care of the using rdns in the hello line and such, but it didn't change the behavior, i still get that same log pattern above. :(
     

    Attached Files:

    Last edited: Jun 9, 2006
  5. falko

    falko Super Moderator ISPConfig Developer

    You should add myorigin, myhostname and mydomain entries in main.cf and restart Postfix.
     
  6. whitty

    whitty New Member

    YAY thanks a bunch, never would have figured it out. I figured ispconfig did stuff like that automatically. Here's another one: the default email address for a user is always [email protected] instead of [email protected], despite an entry in codomains with no hostname, just domain.tld, allowing mail to be sent to [email protected] just fine. This is also new since the system worked last. Is there any way to change that without the user adding their own identity in the mail program?
     
  7. falko

    falko Super Moderator ISPConfig Developer

  8. whitty

    whitty New Member

  9. falko

    falko Super Moderator ISPConfig Developer

    You can change that in the webmail settings. Every user has to configure his email address in the webmail settings, just as you do in any normal email client.
     
  10. whitty

    whitty New Member

    hmm, not quite sure we're on the same page: when i set up an email user for a site "domain.tld", i have no option but to set it up with what it tells me is [email protected]. I then log into webmail with webx_user or [email protected] (Both work) and the default email address that email is sent from for that user is [email protected]. It used to be that when i logged in (when i first had email working this is) i would default to sending email from [email protected] and not have to set up an alias, which would be far more convienient. Is there any way to replicate that without needing to set up the alias manually?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

  12. whitty

    whitty New Member

    No, what i mean is that it works just fine, i can send an email to user@ or webX_user@ anysubdomainhere.domain.tld or domain.tld, but when i log in to webmail with user@ or webX_user@ anysubdomainhere.domain.tld or domain.tld or just webX_user, it defaults to SENDING email from the [email protected] address. Like i said, it can be changed by adding an identity in the mail program to send from one of the other workable addresses, it's just annoying that this is default even when i set the account up with what is supposedly @domain.tld.

    Thanks for continuing to try and help through all this confusion :)
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Yes, I understood this. Every user can change his email address in the webmail program, as he can do in every regular email client. There's no way to change the default address.
     
  14. schmidtedv

    schmidtedv New Member

  15. till

    till Super Moderator Staff Member ISPConfig Developer

    The first email address is shown in the email settings, but ISPConfig creates a co-domain with empty host automatically.

    There will be a feature in the next development release, that the email domans can be selected with a checkbox for each user.
     
  16. schmidtedv

    schmidtedv New Member

Share This Page