Postfix issue - local domains

Discussion in 'Installation/Configuration' started by baboonish, Oct 23, 2007.

  1. baboonish

    baboonish New Member

    I'm wondering if I've configured something incorrectly. If a user of one domain on my server sends an email to a user on another domain who's DNS records are held by my server but mx records point elsewhere, the mail is sent to my postfix server on the same machine.

    Is there a way of having postfix check the mx record and send accordingly before checking whether the domain is handled by this machine?

    postconf -n as follows:

    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    inet_interfaces = all
    inet_protocols = all
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    mydestination = /etc/mail/local-host-names
    myhostname =
    mynetworks =
    myorigin = /etc/mailname
    recipient_delimiter = +
    relayhost =
    smtp_tls_note_starttls_offer = yes
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom

    setup is postfix on ubuntu server 7.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you created a site for this domain in ISPConfig, you will have to set the mailserver to external in the site settings (on the options tab) AND also set all co-domains of this site to external mailserver (on the options tabs of every co-domain).

Share This Page