Postfix issue: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

Discussion in 'Installation/Configuration' started by inturbidus, Sep 22, 2013.

  1. inturbidus

    inturbidus New Member

    I get this error when I try to send mail.

    Sep 22 14:21:51 10-163-97-14 postfix/error[12936]: 12CBA135AFA: to=<[email protected]>, relay=none, delay=41102, delays=41102/0.02/0/0.04, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

    I'm running ISPConfig 3.0.5.3 on CentOS release 5.9 (Final)

    I checked postfix.

    [[email protected] postfix]# postfix status
    postfix/postfix-script: the Postfix mail system is running: PID: 12923
    [[email protected] postfix]# postfix check
    [[email protected] postfix]#

    Here is the bottom of my main.cf file
    readme_directory = /usr/share/doc/postfix-2.5.1-documentation/readme
    alias_database = hash:/etc/postfix/aliases
    alias_maps = hash:/etc/postfix/aliases
    mydomain = stonewall.lynergy.com
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_client_restrictions = check_client_access mysql : /etc/postfix/mysql-virtual_client.cf
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_use_tls = yes
    smtpd_tls_security_level = may
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    transport_maps = hash : /var/lib/mailman/data/transport-mailman, proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
    smtpd_client_message_rate_limit = 100
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = dovecot
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    inet_interfaces = all
    dovecot_destination_recipient_limit = 1
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth
    receive_override_options = no_address_mappings
    content_filter = amavis:[127.0.0.1]:10024
    relayhost =
    mailbox_size_limit = 0
    message_size_limit = 0

    I saw that others had said I need amavisd-new installed. Apparently when I did the perfect server setup I had trouble with this because it doesn't seem to be installed.

    So I attempt to install it with all of it's dependencies (I was able to get clamav and spamassassin installed).

    [[email protected] ~]# yum --enablerepo=rpmforge,rpmforge-extras install amavisd-new clamav clamav-devel clamd spamassassin
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
    * atomic: www6.atomicorp.com
    * base: mirror.symnds.com
    * centosplus: mirror.ash.fastserv.com
    * contrib: mirror.es.its.nyu.edu
    * epel: mirror.cogentco.com
    * extras: mirrors.serveraxis.net
    * rpmforge: mirror.us.leaseweb.net
    * rpmforge-extras: mirror.us.leaseweb.net
    * updates: mirror.ash.fastserv.com
    Excluding Packages from CentOS / Red Hat Enterprise Linux 5 - atomicrocketturtle.com
    Finished
    Excluding Packages from Red Hat Enterprise Linux 5 - i386 - ATrpms
    Finished
    Reducing Red Hat Enterprise Linux 5 - i386 - ATrpms to included packages only
    Finished
    Excluding Packages from Red Hat Enterprise Linux 5 - i386 - ATrpms testing
    Finished
    Reducing Red Hat Enterprise Linux 5 - i386 - ATrpms testing to included packages only
    Finished
    Excluding Packages from CentOS-5 - Base
    Finished
    Reducing CentOS-5 - Plus to included packages only
    Finished
    Excluding Packages from CentOS-5 - Updates
    Finished
    5829 packages excluded due to repository priority protections
    Setting up Install Process
    Package clamav-0.97.8-11.el5.art.i386 already installed and latest version
    Package clamd-0.97.8-11.el5.art.i386 already installed and latest version
    Package 1:spamassassin-3.3.2-7.el5.art.i386 already installed and latest version
    Resolving Dependencies
    --> Running transaction check
    ---> Package amavisd-new.noarch 0:2.4.5-1.el5 set to be updated

    .. Various dependencies..

    --> Running transaction check
    ---> Package amavisd-new.noarch 0:2.4.5-1.el5 set to be updated
    --> Processing Dependency: /etc/clamd.d for package: amavisd-new
    ---> Package lzop.i386 0:1.03-2.el5 set to be updated
    --> Processing Dependency: liblzo2.so.2 for package: lzop
    ---> Package perl-XML-NamespaceSupport.noarch 0:1.09-1.2.1 set to be updated
    --> Processing Dependency: /etc/clamd.d for package: amavisd-new
    --> Finished Dependency Resolution
    amavisd-new-2.4.5-1.el5.noarch from epel has depsolving problems
    --> Missing Dependency: /etc/clamd.d is needed by package amavisd-new-2.4.5-1.el5.noarch (epel)
    amavisd-new-2.4.5-1.el5.noarch from epel has depsolving problems
    --> Missing Dependency: /etc/clamd.d is needed by package amavisd-new-2.4.5-1.el5.noarch (epel)
    lzop-1.03-2.el5.i386 from epel has depsolving problems
    --> Missing Dependency: liblzo2.so.2 is needed by package lzop-1.03-2.el5.i386 (epel)
    Error: Missing Dependency: liblzo2.so.2 is needed by package lzop-1.03-2.el5.i386 (epel)
    Error: Missing Dependency: /etc/clamd.d is needed by package amavisd-new-2.4.5-1.el5.noarch (epel)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest


    I can't seem to get amavisd-new installed.
     
  2. Franz

    Franz Member

    Check if clamav and/or spamassassin are working.
    just restart them via init.d scripts.

    you can also check your syslog if you got some think like this:

    Code:
    Sep 17 01:45:43 server1 kernel: OOM killed process 13544 (clamd) vm:374924kB, rss:54428kB, swap:175144kB
    Sep 17 01:45:52 server1 kernel: OOM killed process 31562 (mysqld) vm:530816kB, rss:109972kB, swap:62336kB
    Sep 17 01:46:02 server1 kernel: OOM killed process 4530 (amavisd-new) vm:216768kB, rss:25852kB, swap:65368kB
    Sep 17 01:46:03 server1 kernel: OOM killed process 8318 (amavisd-new) vm:215508kB, rss:28932kB, swap:60956kB
    Sep 17 01:46:05 server1 kernel: OOM killed process 13634 (amavisd-new) vm:210932kB, rss:772kB, swap:85824kB
    Sep 17 01:46:06 server1 kernel: OOM killed process 11457 (php-cgi) vm:433512kB, rss:144kB, swap:76780kB
    Sep 17 01:46:09 server1 kernel: OOM killed process 11463 (php-cgi) vm:431060kB, rss:272kB, swap:73892kB
    Sep 17 01:46:09 server1 kernel: OOM killed process 11527 (php-cgi) vm:394988kB, rss:24672kB, swap:33740kB
    Sep 17 01:46:09 server1 kernel: OOM killed process 13600 (spamd) vm:128984kB, rss:744kB, swap:49472kB
    Sep 17 01:46:09 server1 kernel: OOM killed process 13601 (spamd) vm:128984kB, rss:776kB, swap:49440kB
    Sep 17 01:46:10 server1 kernel: OOM killed process 13599 (spamd) vm:128984kB, rss:1444kB, swap:48844kB
    Sep 17 01:46:10 server1 kernel: OOM killed process 11935 (php-cgi) vm:398676kB, rss:50856kB, swap:1888kB
    Sep 17 01:46:10 server1 kernel: OOM killed process 11878 (php-cgi) vm:398676kB, rss:50904kB, swap:1880kB
    Sep 17 01:46:10 server1 kernel: OOM killed process 11871 (php-cgi) vm:398676kB, rss:50188kB, swap:2596kB
    Sep 17 01:46:11 server1 kernel: OOM killed process 11893 (php-cgi) vm:399448kB, rss:49392kB, swap:4084kB
    Sep 17 01:46:11 server1 kernel: OOM killed process 11894 (php-cgi) vm:399932kB, rss:52548kB, swap:2132kB
    Sep 17 01:46:13 server1 kernel: OOM killed process 11895 (php-cgi) vm:400460kB, rss:52244kB, swap:3872kB
    Sep 17 01:46:14 server1 kernel: OOM killed process 11896 (php-cgi) vm:400984kB, rss:53088kB, swap:3192kB
    
     
  3. inturbidus

    inturbidus New Member

    It looks like spamassassin wasn't on.

    [[email protected] ~]# /etc/init.d/clamd stop
    Stopping Clam AntiVirus Daemon: [ OK ]
    [[email protected] ~]# /etc/init.d/clamd start
    Starting Clam AntiVirus Daemon: [ OK ]
    [[email protected] ~]# /etc/init.d/spamassassin stop
    Stopping spamd: [FAILED]
    [[email protected] ~]# /etc/init.d/spamassassin start
    Starting spamd: [ OK ]
    [[email protected] ~]#

    However I'm getting the same error.

    Sep 22 19:50:19 10-163-97-14 postfix/smtp[18326]: 5C39A19CC4B: to=<[email protected]>, relay=none, delay=0.18, delays=0.18/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
     
  4. inturbidus

    inturbidus New Member

    I disabled the priorities plugin for yum and it installed amavisd-new.
     
  5. inturbidus

    inturbidus New Member

    I got amavisd, postfix, clamav, spamassassin running and still get the same error:

    Sep 22 16:39:25 10-163-97-14 postfix/error[21828]: AC3BF135AEB: to=<[email protected]>, relay=none, delay=56809, delays=56809/0.18/0/0.05, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
     
  6. inturbidus

    inturbidus New Member

    Looks like amavis is not listening on 10024. I get connection refused when i telnet to 10024 (obviously).

    Sep 22 17:08:38 10-163-97-14 amavis[4726]: (!)Net::Server: 2013/09/22-17:08:38 Couldn't open pid file "/var/run/amavisd/amavisd.pid" [No such file or directory].\n\n at line 318 in file /usr/lib/perl5/vendor_perl/5.8.8/Net/Server.pm
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Which tutrial did you use to prepare your server for the installation of ispconfig?
     

Share This Page