postfix howto problem

Discussion in 'HOWTO-Related Questions' started by learnbash, Jul 10, 2010.

  1. learnbash

    learnbash New Member

    Hello Sir, Falko,

    I have followed below link to implement mailserver on Fedora-32-bit machine, all softwares installed successfully and each step followed as you mentioned in the howto, but i got error when sending email.

    It is bouncing, below is attached logs, Please suggest how to resolve this problem



    Jul 10 10:09:18 server1 postfix/smtp[16293]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
    Jul 10 10:09:18 server1 postfix/smtp[16293]: warning: inet_protocols: configuring for IPv4 support only

    Jul 10 10:09:32 server1 postfix/smtpd[16318]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
    Jul 10 10:09:32 server1 postfix/smtpd[16318]: warning: inet_protocols: configuring for IPv4 support only
    Jul 10 10:09:32 server1 postfix/smtpd[16318]: connect from unknown[127.0.0.1]
    Jul 10 10:09:32 server1 postfix/smtpd[16318]: A484055E980: client=unknown[127.0.0.1]
    Jul 10 10:09:32 server1 postfix/cleanup[16290]: A484055E980: message-id=<[email protected]>
    Jul 10 10:09:32 server1 postfix/qmgr[7328]: A484055E980: from=<[email protected]>, size=1064, nrcpt=1 (queue active)
    Jul 10 10:09:32 server1 postfix/smtp[16322]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
    Jul 10 10:09:32 server1 postfix/smtp[16322]: warning: inet_protocols: configuring for IPv4 support only
    Jul 10 10:09:32 server1 postfix/bounce[16325]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
    Jul 10 10:09:32 server1 postfix/bounce[16325]: warning: inet_protocols: configuring for IPv4 support only
    Jul 10 10:09:32 server1 amavis[7731]: (07731-01) Passed CLEAN, MYNETS LOCAL [192.168.15.52] [192.168.15.52] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: J+BxJy3MN0jC, Hits: -1.009, size: 628, queued_as: A484055E980, 14543 ms
    Jul 10 10:09:32 server1 postfix/smtp[16293]: 2094055E97C: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=15, delays=0.03/0.01/0.01/15, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=07731-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as A484055E980)
    Jul 10 10:09:32 server1 postfix/qmgr[7328]: 2094055E97C: removed
    Jul 10 10:09:32 server1 postfix/smtp[16322]: A484055E980: to=<[email protected]>, relay=none, delay=0.03, delays=0.01/0.01/0/0, dsn=5.4.6, status=bounced (mail for server1.example.com loops back to myself)
    Jul 10 10:09:32 server1 postfix/cleanup[16290]: B124B55E97C: message-id=<[email protected]>
    Jul 10 10:09:32 server1 postfix/bounce[16325]: A484055E980: sender non-delivery notification: B124B55E97C
    Jul 10 10:09:32 server1 postfix/qmgr[7328]: B124B55E97C: from=<>, size=2982, nrcpt=1 (queue active)
    Jul 10 10:09:32 server1 postfix/qmgr[7328]: A484055E980: removed
    Jul 10 10:09:32 server1 postfix/smtp[16322]: B124B55E97C: to=<[email protected]>, relay=none, delay=0.02, delays=0.02/0/0/0, dsn=5.4.6, status=bounced (mail for server1.example.com loops back to myself)
    Jul 10 10:09:32 server1 postfix/qmgr[7328]: B124B55E97C: removed
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Which guide (URL)?

    Please add server1.example.com to the mydestination line in etc/postfix/main.cf and restart Postfix.
     
  3. learnbash

    learnbash New Member

    Thanks for kind reply.

    http://howtoforge.net/virtual-users-domains-postfix-courier-mysql-squirrelmail-fedora-12-x86_64

    the line you mention, its already there, but there is no effect, i am not able to sent email.

    mydestination = server1.example.com, localhost, localhost.localdomain


    above is my setting, i am not sure where is the mistake.

    second is it possible that i can use postfixadmin with same guide. I have configure postfixadmin, but when i create users and domain, it not shows under that directory.
     
    Last edited: Jul 10, 2010
  4. learnbash

    learnbash New Member

    Below is my attached main.cf

    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    data_directory = /var/lib/postfix
    mail_owner = postfix
    inet_interfaces = all
    inet_protocols = all
    mydestination = server1.example.com, localhost, localhost.localdomain
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    ddd $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.7.0/samples
    readme_directory = /usr/share/doc/postfix-2.7.0/README_FILES
    myhostname = server1.example.com
    mynetworks = 127.0.0.0/8
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    smtpd_use_tls = yes
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_create_maildirsize = yes
    virtual_maildir_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
     
  5. falko

    falko Super Moderator ISPConfig Developer

    No, that's not possible because Postfixadmin requires a slightly different setup.


    What domains do you have in the domains table (in the database)?

    Are there any other errors in your mail log?
     
  6. learnbash

    learnbash New Member

    can u help me about this setup.

    1. postfix with virtual domains
    2. dovecot with virtual domains
    3. postfixadmin to create domains.
     

Share This Page