Postfix giving some odd errors

Discussion in 'Installation/Configuration' started by fixallthisjunkguy, Sep 10, 2008.

  1. fixallthisjunkguy

    fixallthisjunkguy New Member

    Good Morning, I'm using Ubuntu 8.04 which I upgraded from 7.10 and Postfix is the newest version downloaded with apt-get. Postfix is giving me the following error message in the mail.log


    mailserver postfix/tlsmgr[22168]: fatal: tls_prng_exch_open: cannot open PRNG exchange file /var/lib/postfix/prng_exch: Permission denied
    mailserver postfix/tlsmgr[22155]: warning: process /usr/lib/postfix/tlsmgr pid 22168 exit status 1
    mailserver postfix/tlsmgr[22155]: warning: /usr/lib/postfix/tlsmgr: bad command startup -- throttling


    ls -la of /var/lib shows:

    drw-r--r-- 2 postfix postfix 4096 2008-09-08 16:$2 postfix


    ls -la of /var/lib/postfix shows:

    -rw-r--r-- 1 postfix 127 1024 2008-09-08 16:42 prng_exch
    -rw-------1 ftp 127 8192 smtpd_scache.db
    -rw-------1 ftp 127 8192 smtp_scache.db



    Does anyone know what the problem might be? I have tried the comments found in one other thread on roughly the same problem. Any help would be appreciated! Thank you very much.
     
  2. fixallthisjunkguy

    fixallthisjunkguy New Member

    Also here is my main.cf from postfix, just in case someone needed to see it to give me an idea of what to fix.



    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    default_process_limit = 15
    message_size_limit = 100000000
    myhostname = mailserver.maplevalefarms.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination =
    relayhost = [mail.alltel.net]
    smtp_sasl_auth_enable = no
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options = noanonymous
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 1000000000
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
     
  3. fixallthisjunkguy

    fixallthisjunkguy New Member

    Ok, I fixed that problem, chmod 700 to all files and the folder /var/lib/postfix then set owners and groups both to postfix user for folder and files.


    Now another problem, phew this is getting annoying....




    Sep 10 11:24:32 mailserver postfix/smtpd[7092]: connect from localhost.localdomain[127.0.0.1]
    Sep 10 11:24:32 mailserver postfix/smtpd[7092]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
    Sep 10 11:24:32 mailserver postfix/smtpd[7092]: warning: localhost.localdomain[127.0.0.1]: SASL LOGIN authentication failed: generic failure
    Sep 10 11:24:32 mailserver postfix/smtpd[7092]: disconnect from localhost.localdomain[127.0.0.1]
     
  4. fixallthisjunkguy

    fixallthisjunkguy New Member

    Wow, I'm an idiot, I fixed that too. Reran adduser postfix sasl and it fixed it.....


    Now I'm getting


    Sep 10 11:27:00 mailserver postfix/postdrop[7438]: warning: mail_queue_enter: create file maildrop/135065.7438: Permission denied
    Sep 10 11:27:00 mailserver postfix/postdrop[7446]: warning: mail_queue_enter: create file maildrop/191682.7446: Permission denied
    Sep 10 11:27:10 mailserver postfix/postdrop[7438]: warning: mail_queue_enter: create file maildrop/137135.7438: Permission denied
    Sep 10 11:27:10 mailserver postfix/postdrop[7446]: warning: mail_queue_enter: create file maildrop/193783.7446: Permission denied
    Sep 10 11:27:20 mailserver postfix/postdrop[7438]: warning: mail_queue_enter: create file maildrop/139263.7438: Permission denied
    Sep 10 11:27:20 mailserver postfix/postdrop[7446]: warning: mail_queue_enter: create file maildrop/195896.7446: Permission denied
    Sep 10 11:27:30 mailserver postfix/postdrop[7438]: warning: mail_queue_enter: create file maildrop/142408.7438: Permission denied
    Sep 10 11:27:30 mailserver postfix/postdrop[7446]: warning: mail_queue_enter: create file maildrop/204888.7446: Permission denied
    Sep 10 11:27:40 mailserver postfix/postdrop[7438]: warning: mail_queue_enter: create file maildrop/143551.7438: Permission denied
    Sep 10 11:27:40 mailserver postfix/postdrop[7446]: warning: mail_queue_enter: create file maildrop/206012.7446: Permission denied
     
  5. fixallthisjunkguy

    fixallthisjunkguy New Member

    I am able to send emails to users within the domain, haven't tried anyone outside of it, but they do go, but I'm still getting these error messages above. Anyone have any good ideas about them?
     
  6. fixallthisjunkguy

    fixallthisjunkguy New Member

    I chmodded 777 to /var/spool/postfix/maildrop and the ownership was set to postfix:postdrop and all appears to be working.

    This is most likely a temporary fix, but, it works for now. If anyone knows a better work around, please let me know, and hopfully if anyone has these problems in the future, the answers are posted here.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Not sure, but maybe AppArmor was the cause for a part of the problems. Did you disable it?
     
  8. fixallthisjunkguy

    fixallthisjunkguy New Member

    Yes, but I'm thinking that maybe I disabled it AFTER I installed postfix, so maybe not all of the folder permissions got applied correctly during the postfix install.....

    Seems like that is something that someone waaaaaay above us would want to make sure doesn't happen. It's ignorant problems like this, which I may have caused, but still, just the fact that it happened. It's problems like this that push the people who don't have patience away from using linux in the first place.
     

Share This Page