Postfix failed to start/restart

Discussion in 'Server Operation' started by SkykerZio, Nov 1, 2007.

  1. SkykerZio

    SkykerZio New Member

    i was following the "perfect setup guide suse 10.2"
    and setting up postfix, and when I get to the restart command, postfix is failing to restart. I followed the commands below, and nothing so far has had a problem till the restart, Is something wrong? or Did I Mess up?

    7 Postfix With SMTP-AUTH And TLS
    Postfix is already installed, but we must install Cyrus-SASL now:

    yast2 -i cyrus-sasl cyrus-sasl-crammd5 cyrus-sasl-digestmd5 cyrus-sasl-gssapi cyrus-sasl-otp cyrus-sasl-plain cyrus-sasl-saslauthd

    Then we add the system startup links for saslauthd and start it:

    chkconfig --add saslauthd
    /etc/init.d/saslauthd start

    Afterwards we create the certificates for TLS:

    mkdir /etc/postfix/ssl
    cd /etc/postfix/ssl/
    openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
    chmod 600 smtpd.key
    openssl req -new -key smtpd.key -out smtpd.csr
    openssl x509 -req -days 3650 -in smtpd.csr -signkey smtpd.key -out smtpd.crt
    openssl rsa -in smtpd.key -out smtpd.key.unencrypted
    mv -f smtpd.key.unencrypted smtpd.key
    openssl req -new -x509 -extensions v3_ca -keyout cakey.pem -out cacert.pem -days 3650

    Next we configure Postfix for SMTP-AUTH and TLS:

    postconf -e 'mydomain ='
    postconf -e 'myhostname = server1.$mydomain'
    postconf -e 'mynetworks ='
    postconf -e 'smtpd_sasl_local_domain ='
    postconf -e 'smtpd_sasl_auth_enable = yes'
    postconf -e 'smtpd_sasl_security_options = noanonymous'
    postconf -e 'broken_sasl_auth_clients = yes'
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains'
    postconf -e 'inet_interfaces = all'
    postconf -e 'alias_maps = hash:/etc/aliases'
    postconf -e 'smtpd_tls_auth_only = no'
    postconf -e 'smtp_use_tls = yes'
    postconf -e 'smtpd_use_tls = yes'
    postconf -e 'smtp_tls_note_starttls_offer = yes'
    postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'
    postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'
    postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'
    postconf -e 'smtpd_tls_loglevel = 1'
    postconf -e 'smtpd_tls_received_header = yes'
    postconf -e 'smtpd_tls_session_cache_timeout = 3600s'
    postconf -e 'tls_random_source = dev:/dev/urandom'

    To enable TLS connections in Postfix, edit /etc/postfix/ and uncomment the tlsmgr line so that it looks like this one:

    vi /etc/postfix/

    tlsmgr unix - - n 1000? 1 tlsmgr

    Now restart Postfix:

    /etc/init.d/postfix restart
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
    What's the output of
    postconf -n

Share This Page