Postfix errors after uninstalling ISPConfig

Discussion in 'Installation/Configuration' started by Zedix, Dec 15, 2005.

  1. Zedix

    Zedix New Member

    Hi,
    It seems ISPConfig is still interferring with postfix after having uninstalled ISPConfig. Its still trying to send a RCPT to admispconfig's user (which doesn't exist). I've been trying to find how it's still interferring, without luck. Here's a sample of the maillog :

    Code:
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: mail_addr_find: [email protected] -> (not found)
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: NOQUEUE: reject: RCPT from dwebX[127.0.0.1]: 450 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<ns1.xxxxxxx.com>
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: > dwebX[127.0.0.1]: 450 <[email protected]>: Recipient address rejected: User unknown in local recipient table
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: watchdog_pat: 0x94e2430
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: < dwebX[127.0.0.1]: DATA
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: > dwebX[127.0.0.1]: 554 Error: no valid recipients
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: watchdog_pat: 0x94e2430
    Dec 14 20:51:30 ns1 sendmail[15185]: jBF1pUVv015185: [email protected], ctladdr=web1_robey (10002/10001), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30105, relay=[127.0.0.1] [127.0.0.1], dsn=4.2.0, stat=Deferred: 450 <[email protected]>: Recipient address rejected: User unknown in local recipient table
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: < dwebX[127.0.0.1]: RSET
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: > dwebX[127.0.0.1]: 250 Ok
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: watchdog_pat: 0x94e2430
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: < dwebX[127.0.0.1]: QUIT
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: > dwebX[127.0.0.1]: 221 Bye
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: disconnect from dwebX[127.0.0.1]
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: master_notify: status 1
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: connection closed
    Dec 15 01:51:30 ns1 postfix/smtpd[15177]: watchdog_stop: 0x94e2430
    
    Any help is appreciated :) Thanks.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You seem to have some of these mails in your mail queue. Because you've uninstalled ISPConfig in the meantime, they can't be delivered.

    Run
    Code:
    postqueue -p
    to see what's in your mail queue. To delete all mails in the queue, run this:
    Code:
    postsuper -d ALL
    To delete a specific mail, you must know its id, as shown by
    Code:
    postqueue -p
    . Then run
    Code:
    postsuper -d <id>
     

Share This Page