Postfix error

Discussion in 'HOWTO-Related Questions' started by rh-penguin, Nov 22, 2006.

  1. rh-penguin

    rh-penguin New Member

    hi,

    Im using the perfect setup howto for suse 10.1 (ISP/Server installation) i was doing ok till Step 7 Postfix With SMTP-AUTH And TLS. I edited /etc/postfix/master.cf, restarted postfix, called: telnet localhost 25 and got the following:
    Code:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 dude.spenguin.net ESMTP Postfix
    421 dude.spenguin.net Error: timeout exceeded
    Connection closed by foreign host.
    Can someone fetch me an idea of what could be wrong and how i could fix this?

    Thanks Alot!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    When you see
    Code:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 dude.spenguin.net ESMTP Postfix
    you must type
    Code:
    ehlo localhost
    If you don't or wait too long you'll get this timeout.
     
  3. rh-penguin

    rh-penguin New Member

    ooooooo......Gotcha!
    I'll try that, hopefully it works.
    Thanks!
     
  4. rh-penguin

    rh-penguin New Member

    once i typed 'ehlo localhost' i Did get a
    Code:
    250-STARTLS
    however, i didnt get
    PHP:
    250-AUTH
    Is that something to worry about?> What could be wrong now?
     
  5. falko

    falko Super Moderator ISPConfig Developer

    This means that SMTP-AUTH doesn't work. What is the exact output?

    Maybe you should compare your configuration again with the one from the tutorial.
     
  6. rh-penguin

    rh-penguin New Member

    Nevermind, I thaught it had to say 250-AUTH Exactly; but the exact output i had was:
    Code:
    [[email protected] ssl]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    220 server1.xxxxx.xx ESMTP Postfix
    ehlo localhost
    250-server1.xxxxx,xx
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250 8BITMIME
    
    Thanks!
     
    Last edited: Dec 4, 2006
  7. falko

    falko Super Moderator ISPConfig Developer

    Looks fine! :)
     
  8. todgerme

    todgerme Member


    Try handing mail off to the server before any DNS changes, see if it all works well:

    # telnet localhost 25

    > helo domain.com
    > mail from:<[email protected]>
    > rcpt to:<[email protected]>
    > data
    > test
    > .
     

Share This Page