Postfix error on debian 9

Discussion in 'ISPConfig 3 Priority Support' started by sdesprez, Jan 11, 2018.

  1. sdesprez

    sdesprez New Member HowtoForge Supporter

    hello
    I have the error named[878]: SERVFAIL unexpected RCODE resolving '0.80.84.194.in-addr.arpa/PTR/IN': 193.232.88.17#53
    I don't understand
    Thank you very much for your help
    Regards
    Sylvain
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This message just means an IP address has no reverse dns record.
     
  3. sdesprez

    sdesprez New Member HowtoForge Supporter

    PTR added
    But problem to send email

    /etc/postfix# postqueue -vf
    postqueue: name_mask: all
    postqueue: inet_addr_local: configured 7 IPv4 addresses
    postqueue: inet_addr_local: configured 19 IPv6 addresses
    postqueue: warning: unix_trigger: connect to public/qmgr: Connection refused
    postqueue: fatal: Cannot flush mail queue - mail system is down
     
  4. sdesprez

    sdesprez New Member HowtoForge Supporter

    Jan 11 23:56:36 postfix/postfix-script[4178]: starting the Postfix mail system
    Jan 11 23:56:36 postfix/master[4180]: fatal: bind X.Y.Z.W port 465: Address already in use
    Jan 11 23:56:37 postfix/master[4179]: fatal: daemon initialization failure
    Jan 11 23:56:38 postfix/postfix-script[4181]: fatal: mail system startup failed
    Jan 11 23:56:39 systemd[1]: [email protected]: Control process exited, code=exited status=1
    Jan 11 23:56:39 systemd[1]: Failed to start Postfix Mail Transport Agent (instance -).
    Jan 11 23:56:39 systemd[1]: [email protected]: Unit entered failed state.
    Jan 11 23:56:39 systemd[1]: [email protected]: Failed with result 'exit-code'.
    Jan 11 23:56:39 systemd[1]: Starting Postfix Mail Transport Agent...
    Jan 11 23:56:39 systemd[1]: Started Postfix Mail Transport Agent.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    please post the output of:

    netstat -ntap | grep 465
     
  6. sjau

    sjau Local Meanie Moderator

    Somthing is listening on port 465 - what is that port even used for?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Port 465 is SMTPS, but normally it is not used as one would use port 587 or 25.
     
  8. sdesprez

    sdesprez New Member HowtoForge Supporter

    postfix# netstat -ntap | grep 465
    No response
    Why i have Adress already in use
    I configurate server email mode TLS --> 465
    ------------------------------------------------------------------
    the example of the net is correct or no ?
    Solution - Postfix version 2.7 or above required:
    /etc/postfix/master.cf

    #smtp inet n - n - - smtpd
    127.0.0.1:smtp inet n - n - - smtpd
    -o syslog_name=postfix-localhost
    -o smtp_helo_name=localhost
    -o smtp_bind_address=127.0.0.1
    -o myhostname=localhost

    65.xxx.xxx.100:smtp inet n - n - - smtpd
    -o syslog_name=postfix-mail.abc.com
    -o smtp_helo_name=mail.abc.com
    -o smtp_bind_address=65.xxx.xxx.100
    -o myhostname=mail.abc.com

    65.xxx.xxx.200:smtp inet n - n - - smtpd
    -o syslog_name=postfix-mail.xyz.com
    -o smtp_helo_name=mail.zyx.com
    -o smtp_bind_address=65.xxx.xxx.200
    -o myhostname=mail.xyz.com

    abc-out unix - - n - - smtp
    -o smtp_bind_address=65.xxx.xxx.100
    -o smtp_helo_name=mail.abc.com
    -o syslog_name=postfix-mail.abc.com

    xyz-out unix - - n - - smtp
    -o smtp_bind_address=65.xxx.xxx.200
    -o smtp_helo_name=mail.xyz.com
    -o syslog_name=postfix-mail.xyz.com

    I don't understand my error.

    Could you please help me

    /etc/postfix/main.cf

    sender_dependent_default_transport_maps = hash:/etc/postfix/sender_transport

    /etc/postfix/sender_transport

    # Use source IP - 65.xxx.xxx.100
    @abc.com abc-out:
    @example.com abc-out:

    # Use source IP - 65.xxx.xxx.200
    @xyz.com xyz-out:

    Run command to generate hash db

    postmap hash:/etc/postfix/sender_transport

    Restart/Reload postfix

    service postfix reload

    --------------
    i replace
    65.xxx.xxx.100:smtp inet n - n - - smtpd
    -o syslog_name=postfix-mail.abc.com
    -o smtp_helo_name=mail.abc.com
    -o smtp_bind_address=65.xxx.xxx.100
    -o myhostname=mail.abc.com
    by
    65.xxx.xxx.100:smtps inet n - n - - smtpd s for TLS
    -o syslog_name=postfix-mail.abc.com
    -o smtp_helo_name=mail.abc.com
    -o smtp_bind_address=65.xxx.xxx.100
    -o myhostname=mail.abc.com
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you probably defined the smtps port twice in master.cf file.
     

Share This Page