Postfix error: email loops back

Discussion in 'Installation/Configuration' started by torusturtle, Jul 5, 2006.

  1. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Hi I updated ISPConfig and all works well. There is one problem though. A web that did cause problems before still cases problems.

    The most recent one is that I can't receive emails on any adress of that web anymore.

    I receive an error message by mail:

    What does this mean?

    Thanks for your advice.
     
  2. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    I could fix it.

    Deleted it and made a new web with new email adresses.
     
  3. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    I take it back.
    It worked for one email. Now I get the same error report again!
    Very odd.

    Any ideas?
     
  4. DerLobo

    DerLobo New Member

    Hello,

    ad casecapromotions.ch to virtual domain config file and restart your proftpd

    I'm not sure what the exact name of this file is, but you will find it in the same directory where the postfix conf file is.
     
  5. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    How do I restart proftpd?
     
  6. Jordy

    Jordy New Member

    typ: service proftpd restart
     
  7. falko

    falko Super Moderator ISPConfig Developer

    This has nothing to do with proftpd. Add casecapromotions.ch to /etc/postfix/local-host-names (at the bottom) and restart Postfix. That's all. :)
     
  8. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    I added the domain with www. and without www.

    It works now if I send the email to the @www.domain.tld address. It doesn't work with the @domain.tld address.
     
  9. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    And emails to some email adresses with @domain.tld get written into /var/spool/root
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

  11. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    If you mean if there is a website under the Co-Domain tab, no there isn't
    Yes, there is a entry with an empty host. I used it to forward the domain to another domain.
     
  12. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Settings are now like this:

    Basis
    -----
    Hostname "www"
    Domain "domain.tld"

    Co-Domains
    -----------
    Hostname "www"
    Domain "domain.tld"

    Is there something else that should be done?
     
  13. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    When using thunderbird I get the following error:

    Where do I find this recipient table?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Empty the filed Hostname in the co-domain, otherwise you wont get any emails for ...@domain.tld
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    This problem is solved when you empty the hostname in the co-domain as i described in the other post.
     
  16. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Yes, that solved the problem!
    Thanks.

    But for what is that hostname field good?
     
  17. falko

    falko Super Moderator ISPConfig Developer

    It lets you add other Co-Domains, like for example, www2.example.com, shop.yourdomain.net, etc.
     

Share This Page