postfix error after upgrade

Discussion in 'General' started by kwickcut, Sep 30, 2011.

  1. kwickcut

    kwickcut Member

    hello all i have just upgraded to ubuntu 10.04 and ispconfig 3.0.3.3 and now i am having troubles

    first thing is in ispconfig under Status of Services it shows dns- server is not running and smtp server is not running.

    now i restarted postfix
    Code:
    sudo /etc/init.d/postfix restart
    and it is running but it still shows not running under under ispconfig.


    when i goto a site and send an email i am getting the following error
    Code:
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    i i found that this could mean that amavis is not running so i did the following

    Code:
    postconf -e 'content_filter = amavis:[127.0.0.1]:10024'
    
    Reload/Restart postfix ..
    Code:
    postfix reload
    And check if amavis is running..
    Code:
    netstat -tap | grep amavis
    (you should see a LISTEN port..) but i dont get anything

    any ideas


    kwick
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You have to upgrade ispconfig after you upgraded ubuntu and then select to reconfigure services in ispconfig. If you upgraded ispconfig first, then you have to do a manual ispconfig update now and choose to reconfigure services.
     
  3. kwickcut

    kwickcut Member

    ok i did upgrade ubuntu first then ungraded ispconfig. where would i find this reconfigure services in ispconfig



    kwick
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    download ispconfig tar.gz, unpack it and then run upfate.php script again.
     
  5. kwickcut

    kwickcut Member

    so should i
    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install/
    then run
    Code:
    php -q install.php
    and do the set up again like i did when i first installed ispconfig?

    and this will not bother any sites that are running?

    thanks again

    kwick
     
  6. kwickcut

    kwickcut Member

    ok i have downloaded and ran the update script and i have the save issue postfix is running but ispconfig does not see it i think went wrong with the upgrade of Ubuntu



    kwick
     
  7. kwickcut

    kwickcut Member

    UPDATE
    i cant start amavisd this is what i get when i try any ideas?


    Code:
    root@myhost:~# sudo /etc/init.d/amavis restart
    Stopping amavisd: (not running).
    Starting amavisd: hostname: Name or service not known
      The value of variable $myhostname is "", but should have been
      a fully qualified domain name; perhaps uname(3) did not provide such.
      You must explicitly assign a FQDN of this host to variable $myhostname
      in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
      network name!
    
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Open your amavisd configuration and set the correct $myhostname value (usually localhost should work).
     
  9. kwickcut

    kwickcut Member

    sorry for this but i cant find the config file unless it is this
    Code:
    /etc/amavis/conf.d/15-content_filter_mode
    if this is it this is the output and i am not sure where to add it

    Code:
    use strict;
    
    # You can modify this file to re-enable SPAM checking through spamassassin
    # and to re-enable antivirus checking.
    
    #
    # Default antivirus checking mode
    # Uncomment the two lines below to enable it
    #
    
    @bypass_virus_checks_maps = (
       \%bypass_virus_checks, \@bypass_virus_checks_acl, \$bypass_virus_checks_re);
    
    
    #
    # Default SPAM checking mode
    # Uncomment the two lines below to enable it
    #
    
    @bypass_spam_checks_maps = (
       \%bypass_spam_checks, \@bypass_spam_checks_acl, \$bypass_spam_checks_re);
    
    1;  # insure a defined return
    

    kwick
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you check the other files in the /etc/amavis/conf.d/ directory (and also in the parent directory /etc/amavis/)?
     
  11. kwickcut

    kwickcut Member

    ok i have taken some pictures of the directories as maybe it would make it easier i hope this helps thanks


    kwick
     

    Attached Files:

  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You can find the correct file by running

    Code:
    cd /etc/amavis
    grep -Ri myhostname
     
  13. kwickcut

    kwickcut Member

    i was able to change directories but when i run
    Code:
    grep -Ri myhostname
    i get no output
    Code:
    0 packages can be updated.
    0 updates are security updates.
    
    No mail.
    Last login: Sun Oct  2 11:24:27 2011 from 192.168.1.102
    root@kwickxxxxxx:~# cd /etc/amavis
    root@kwickxxxxxx:/etc/amavis# grep -Ri myhostname
     

    Attached Files:

  14. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you post the outputs of
    Code:
    uname
    ,
    Code:
    hostname
    , and
    Code:
    hostname -f
    ? I guess your system does not have a proper hostname.
     
  15. kwickcut

    kwickcut Member

    root@kwickservers:~# uname
    Linux

    root@kwickservers:~# hostname
    kwickservers.com

    root@kwickservers:~# hostname -f
    hostname: Name or service not known



    kwick
     
  16. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please run
    Code:
    echo kwickservers.com > /etc/hostname
    /etc/init.d/hostname.sh start
    Afterwards, run

    Code:
    hostname
    hostname -f
    Both should show kwickservers.com now.
     
  17. kwickcut

    kwickcut Member

    root@kwickservers:~# /etc/init.d/hostname.sh start
    -bash: /etc/init.d/hostname.sh: No such file or directory
     
  18. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Sorry - it's
    Code:
    /etc/init.d/hostname start
    instead of
    Code:
    /etc/init.d/hostname.sh start
     
  19. kwickcut

    kwickcut Member

    thank you all fixed



    kwick
     

Share This Page