Postfix email server config

Discussion in 'Server Operation' started by veremchook, Feb 14, 2008.

  1. veremchook

    veremchook New Member

    I've recently set up a dedicated postfix server on fc8. When I send an email to one of my xxx domain accounts I get the following:

    Final-Recipient: rfc822; [email protected]
    Action: failed
    Status: 4.0.0
    Diagnostic-Code: X-INTERIA-PL; connect to[XXX.XXX.XXX.XXX]:
    Connection refused

    The domain name and ip address are correct, so I don't think it's a dns issue.

    My file (uncommented lines only, most of them are dafault values):

    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    myhostname = xxx
    (xxx it's the LAN machine name)
    mydomain =
    myorigin =
    inet_interfaces = localhost
    mydestination = $myhostname, localhost.$mydomain, localhost, $myhostname.$mydomain, /etc/postfix/mydestination
    unknown_local_recipient_reject_code = 550
    mynetworks_style = subnet
    relay_domains = $mydestination
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
    xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.4.5/samples
    readme_directory = /usr/share/doc/postfix-2.4.5/README_FILES

    Some additional info:

    [root@xxx ~]# cat /etc/passwd | grep adam

    [root@xxx ~]# chkconfig --list | grep postfix
    postfix 0:eek:ff 1:eek:ff 2:eek:n 3:eek:n 4:eek:n 5:eek:n 6:eek:ff

    [root@xxx ~]# ps aux | grep postfix
    root 1469 0.0 0.3 6940 1796 ? Ss Feb08 0:00 /usr/libexec/postfix/master
    postfix 1476 0.0 0.3 7064 1836 ? S Feb08 0:00 qmgr -l -t fifo -u
    postfix 19091 0.0 0.3 7004 1776 ? S 17:05 0:00 pickup -l -t fifo -u
    root 19113 0.0 0.1 4048 680 pts/0 S+ 17:14 0:00 grep postfix

    The port forwarding on our gateway also seems to be fine. I'm using SpeedTouch 5x6 "Game & Application Sharing" tool.
    hits on port 110 (pop3) are set to be redirected to xxx:110
    hits on port 25 (smtp) are set to be redirected to xxx:25

    Please help and advise where to dig to solve my problem and start some basic email exchange on my server.
  2. topdog

    topdog New Member HowtoForge Supporter

    The issue is connections are not being allowed to port 25 on your server.

    To verify test it from a different location
    nc your_server_ip 25
  3. veremchook

    veremchook New Member

    Thanks, I tried the following:

    [root@xxx ~]# nc -v my_gateway_ip 110
    nc: connect to my_gateway_ip port 110 (tcp) failed: Connection refused
    [root@xxx ~]# nc -v my_gateway_ip 25
    nc: connect to my_gateway_ip port 25 (tcp) failed: Connection refused

    In the same time in my gateway logs I get the following:

    00:40:49 (since last boot) FIREWALL rule (1 of 1) : Protocol: TCP Src ip: some_external_ip Src port: 51090 Dst ip: postfix_server_internal_ip Dst port: 110 Chain: forward_host_service Rule Id: 11 Action: accept

    00:40:51 (since last boot) FIREWALL rule (1 of 4) : Protocol: TCP Src ip: some_external_ip Src port: 44892 Dst ip: postfix_server_internal_ip Dst port: 25 Chain: forward_host_service Rule Id: 12 Action: accept

    I even tried to disable the firewall completely with the sam nc response (Connection refused)
    Any suggestions?
  4. topdog

    topdog New Member HowtoForge Supporter

    Something is wrong with your port forwarding, you need to use tcpdump to debug it.
  5. veremchook

    veremchook New Member

    To me it looks like packets go through:

    [root@xxx ~]# tcpdump | grep some_external_ip

    15:21:21.365433 IP some_external_ip.37849 > postfix_server_internal_ip.pop3: S 3011648941:3011648941(0) win 5840 <mss 1452,sackOK,timestamp 450822963 0,nop,wscale 6>

    15:21:26.058233 IP some_external_ip.42605 > postfix_server_internal_ip.smtp: S 3092138727:3092138727(0) win 5840 <mss 1452,sackOK,timestamp 450823431 0,nop,wscale 6>
  6. topdog

    topdog New Member HowtoForge Supporter

    Yes packets are going in but the response is not coming back.
  7. veremchook

    veremchook New Member

    So there is something wrong with my postfix config if it doesn't respond, right?
    Can you spot the culprit reading my first post?
  8. topdog

    topdog New Member HowtoForge Supporter

    This is not a postfix problem its an issue with your networking.

    On the server it self check try this
    nc 25
    It should respond with the banner.
  9. veremchook

    veremchook New Member


    [root@xxx ~]# nc -v 25
    Connection to 25 port [tcp/smtp] succeeded!
    220 xxx ESMTP Postfix
    421 4.4.2 xxx Error: timeout exceeded
  10. topdog

    topdog New Member HowtoForge Supporter

    Yap like a said the problem is not a postfix problem it is a networking problem to do with either your routing, port forwarding or firewalling.
  11. NewMee

    NewMee New Member

    Check the gateway address on the Postfix machine, if it's not correct, there cannot be an answer on any other network.

    Would give something like this:
    Kernel IP routing table
    Destination     Gateway         Genmask          Flags Metric Ref    Use Iface    *         U     1      0       0 eth0
    default         you.rr.ou.ter         UG    0      0       0 eth0
    where you.rr.ou.ter should be the address of your gateway.

Share This Page