postfix email loop

Discussion in 'Installation/Configuration' started by ru916b, May 2, 2007.

  1. ru916b

    ru916b New Member

    Please help. I got thousands of emails loop back with following message.

    I followed perfect setup on Fedora Core 5.

    -- I want to know where I can change the admispconfig's email?
    -- How to configure postfix to avoid the loop?

    Thanks,

    -- James


    ================================================
    This is the Postfix program at host www.mydomain.com.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <[email protected]>: mail for
    localhost.localdomain.mydomain.com loops back to myself
    ===================================================
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ADMISPConfig has no mailbox. The email sent to admispconfig generate the email statistics and where processed by a script. You can not change this and there is no need to change this.


    add the line:

    localhost.localdomain.mydomain.com

    at the end of the file

    /etc/postfix/local-host-names

    and restart postfix.
     
  3. ru916b

    ru916b New Member

    Till, thanks. Adding the line solves the problem. -- James
     
  4. Dizfunkshunal

    Dizfunkshunal New Member

    OK i have the same problem checked my email this morning had a little over 600k+ of these email. I tried the above with no success. any other ideas?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the exact error message.
     
  6. Dizfunkshunal

    Dizfunkshunal New Member

    This is the mail system at host server1.dizfunkshunal.com.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system

    <[email protected]>: mail for
    localhost.localdomain.dizfunkshunal.com loops back to myself
     

    Attached Files:

  7. Dizfunkshunal

    Dizfunkshunal New Member

    HELP lmao I'm getting these emails faster then I can delete them. I have to receive mail and watch it when it gets to2 or 3 k i have to hit stop If i download any more then that outlook express crashes. last count even after spending 20 minutes deleting was 650k and rising lol
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Add the line:

    localhost.localdomain.dizfunkshunal.com

    at the end of the file /etc/postfix/local-host-names and restart postfix.
     
  9. Dizfunkshunal

    Dizfunkshunal New Member

    I done the edit now to delete all them damn emails lol to see if it works
     
  10. Dizfunkshunal

    Dizfunkshunal New Member

    that did not fix it. any other suggestions?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The above solution is correct if you added the line at the end of the local-host-names file. Please have a look in your mail log, which error messages do you get there.
     
  12. Dizfunkshunal

    Dizfunkshunal New Member

    ok I double checked and I guess it didnt take the first time i edited the file. I must have messed up when trying to save it. Im not getting those emails no more. Which is good bad thing is Im not getting anything anymore. no error messages either.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the lines that appear in the mail log when you send a message to your server.
     
  14. Dizfunkshunal

    Dizfunkshunal New Member

    this is going to sound stupid but where is the log for mail?
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Either: /var/log/mail.log, /var/log/mail or /var/log/maillog depending on your linux distribution.
     
  16. Dizfunkshunal

    Dizfunkshunal New Member

    Thanks it appears i am being blocked be everyone lol hotmail spamhuase bellsouth lol something about smtp auth. oh well Ill turn it off im not that good to get into to fixing all that. Thanks for all the help. I appreciate it.
     
  17. VT-Linux

    VT-Linux New Member

    I'm having the same problem i have added the steps above to the mentioned above. should i post last part of log files and postconf-n ?

    Dig results www.vtpchelp.com
    pcsol-web02:~# dig vtpchelp.com mx

    ; <<>> DiG 9.3.4 <<>> vtpchelp.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42175
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;vtpchelp.com. IN MX

    ;; ANSWER SECTION:
    vtpchelp.com. 60 IN MX 5 mail.vtpchelp.com.

    ;; ADDITIONAL SECTION:
    mail.vtpchelp.com. 60 IN A 75.68.207.13

    ;; Query time: 36 msec
    ;; SERVER: 192.168.10.1#53(192.168.10.1)
    ;; WHEN: Thu Jan 10 14:48:39 2008
    ;; MSG SIZE rcvd: 67
     
    Last edited: Jan 10, 2008
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    @ VT-Linux: Just add the domain name which is mentioned in the error message at the end of the file /etc/postfix/local-host-names and restart postfix.
     
  19. VT-Linux

    VT-Linux New Member

    Thank you Till that resolved the email loop message now I cannot recieve a reply to the message.

    This is from the last part of the mail log:

    Jan 11 15:21:52 www postfix/smtpd[24460]: 60C314D4C7A: client=py-out-1112.google.com[64.233.166.180]
    Jan 11 15:21:52 www postfix/cleanup[24443]: 60C314D4C7A: message-id=<[email protected]>
    Jan 11 15:21:52 www postfix/qmgr[11008]: 60C314D4C7A: from=<[email protected]>, size=2630, nrcpt=1 (queue active)
    Jan 11 15:21:52 www postfix/pickup[23965]: 8C7824D4C7E: uid=10008 from=<web7_gking>
    Jan 11 15:21:52 www postfix/cleanup[24443]: 8C7824D4C7E: message-id=<[email protected]>
    Jan 11 15:21:52 www postfix/local[24463]: 60C314D4C7A: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.24, delays=0.19/0.01/0/0.04, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jan 11 15:21:52 www postfix/qmgr[11008]: 60C314D4C7A: removed
    Jan 11 15:21:52 www postfix/qmgr[11008]: 8C7824D4C7E: from=<[email protected]>, size=368, nrcpt=1 (queue active)
    Jan 11 15:21:52 www postfix/local[24463]: 8C7824D4C7E: to=<[email protected]>, relay=local, delay=0.04, delays=0.02/0/0/0.02, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jan 11 15:21:52 www postfix/qmgr[11008]: 8C7824D4C7E: removed
    Jan 11 15:22:22 www postfix/smtpd[24460]: disconnect from py-out-1112.google.com[64.233.166.180]
     
    Last edited: Jan 11, 2008
  20. falko

    falko Super Moderator ISPConfig Developer

    Which distribution are you using? What's the output of
    Code:
    netstat -tap
    ? Do you use mbox or Maildir?
     

Share This Page