PostFix Email Issue

Discussion in 'Installation/Configuration' started by Seema, Jun 20, 2011.

  1. Seema

    Seema New Member

    Hi!
    I am new to Linux and have very basic understanding about networking...

    I am using Linux Centos 5 installed Postfix and configured as per the tutorial:
    http://www.linuxmail.info/postfix-smtp-server-howto-centos-5/

    I have a static IP address and I have created valid user id's who are within the organization. I am not allowing emails to go outside the domain or receive either.

    I want to send mail notification to users using Project-Open software and the mail does not go from the client side.

    This is how it appears in the maillog file:

    Jun 20 15:38:56 localhost postfix/qmgr[19802]: 40A88B807F: from=<[email protected]>, size=932, nrcpt=1 (queue active)
    Jun 20 15:38:56 localhost postfix/qmgr[19802]: 40A88B807F: to=<[email protected]>, relay=none, delay=5824, delays=5824/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to mail.messaging.microsoft.com[216.32.180.22]: Connection refused)

    My main.cf files looks like this: (everything is # out or left alone by default -based as per the above mentioned tutorial)

    # LOCAL PATHNAME INFORMATION
    #
    # The queue_directory specifies the location of the Postfix queue.
    # This is also the root directory of Postfix daemons that run chrooted.
    # See the files in examples/chroot-setup for setting up Postfix chroot
    # environments on different UNIX systems.
    #
    queue_directory = /var/spool/postfix

    # The command_directory parameter specifies the location of all
    # postXXX commands.
    #
    command_directory = /usr/sbin

    # The daemon_directory parameter specifies the location of all Postfix
    # daemon programs (i.e. programs listed in the master.cf file). This
    # directory must be owned by root.
    #
    daemon_directory = /usr/libexec/postfix

    # QUEUE AND PROCESS OWNERSHIP
    #
    # The mail_owner parameter specifies the owner of the Postfix queue
    # and of most Postfix daemon processes. Specify the name of a user
    # account THAT DOES NOT SHARE ITS USER OR GROUP ID WITH OTHER ACCOUNTS
    # AND THAT OWNS NO OTHER FILES OR PROCESSES ON THE SYSTEM. In
    # particular, don't specify nobody or daemon. PLEASE USE A DEDICATED
    # USER.
    #
    mail_owner = postfix

    # The default_privs parameter specifies the default rights used by
    # the local delivery agent for delivery to external file or command.
    # These rights are used in the absence of a recipient user context.
    # DO NOT SPECIFY A PRIVILEGED USER OR THE POSTFIX OWNER.
    #
    #default_privs = nobody

    # INTERNET HOST AND DOMAIN NAMES
    #
    # The myhostname parameter specifies the internet hostname of this
    # mail system. The default is to use the fully-qualified domain name
    # from gethostname(). $myhostname is used as a default value for many
    # other configuration parameters.
    #
    myhostname = project-open
    #myhostname = virtual.domain.tld

    # The mydomain parameter specifies the local internet domain name.
    # The default is to use $myhostname minus the first component.
    # $mydomain is used as a default value for many other configuration
    # parameters.
    #
    mydomain = localhost.localdomain

    # SENDING MAIL
    #
    # The myorigin parameter specifies the domain that locally-posted
    # mail appears to come from. The default is to append $myhostname,
    # which is fine for small sites. If you run a domain with multiple
    # machines, you should (1) change this to $mydomain and (2) set up
    # a domain-wide alias database that aliases each user to
    # [email protected]st.
    #
    # For the sake of consistency between sender and recipient addresses,
    # myorigin also specifies the default domain name that is appended
    # to recipient addresses that have no @domain part.
    #
    myorigin = $myhostname
    myorigin = $mydomain

    # RECEIVING MAIL

    # The inet_interfaces parameter specifies the network interface
    # addresses that this mail system receives mail on. By default,
    # the software claims all active interfaces on the machine. The
    # parameter also controls delivery of mail to user@[ip.address].
    #
    # See also the proxy_interfaces parameter, for network addresses that
    # are forwarded to us via a proxy or network address translator.
    #
    # Note: you need to stop/start Postfix when this parameter changes.
    #
    inet_interfaces = all
    #inet_interfaces = $myhostname
    #inet_interfaces = $myhostname, localhost
    #inet_interfaces = localhost

    I know I am missing something please help me figure this out. :confused:
    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. Seema

    Seema New Member

    PostFix Email Send

    Hello,
    No it's not blacklisted. I am able to send/receive emails thru my exchange server to any domain outside the organization. Using Postfix however, I am not. I just want to SEND mails not RECEIVE mails...
    Thxs
     
  4. Seema

    Seema New Member

    Postfix (Solved)

    Hi!
    Solved it finally...
    It was the relayhost all the time was pointing in to the wrong path...
    Thxs
    :)
     

Share This Page