Postfix / Dovecot

Discussion in 'Server Operation' started by bscottMD, Aug 16, 2012.

  1. bscottMD

    bscottMD New Member

    I am having some issues configuring outlook to work with postfix / dovecot.

    I can receive mail to the domain but cannot send.

    I have done the following:

    email account setup using the following:

    Code:
    IMAP
    
    Incoming mail server: mail.domain.com
    outgoing mail server: mail.domain.com
    
    SPA (Unchecked)
    
    More Settings: Outgoing Server
    
    Authentication (Unchecked)
    Test results say: Completed

    However when sending mail I get:

    Code:
    The following recipient(s) cannot be reached:
    
          'name@domain.com' on 8/15/2012 7:10 PM
                554 5.7.1 <name@domain.com>: Relay access denied
    
    Now with the "My outgoing server (SMTP) requires authentication checked with "Use the same settings......" checked the test asks for my credentials which I have tried both username and username@domain.com (both reject)

    telnet replies:

    Code:
    220 PostfixMail ESMTP Postfix (Ubuntu)
    ehlo domain.com
    250-PostfixMail
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH GSSAPI DIGEST-MD5 CRAM-MD5 NTLM PLAIN LOGIN ANONYMOUS
    250-AUTH=GSSAPI DIGEST-MD5 CRAM-MD5 NTLM PLAIN LOGIN ANONYMOUS
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    Any thoughts?
     
  2. bscottMD

    bscottMD New Member

    Addition:

    main.cf
    Code:
    #See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = no
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
    smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
    smtpd_use_tls=yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = PostfixMail, localhost, mdoor.com, localhost.localdomain, ubuntufileserver, postfixmail.domain.com
    mynetworks = 127.0.0.0/8, 172.16.16.0/20
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_protocols = all
    inet_portocols = IPv4
    home_mailbox = Maildir/
    myhostname = PostfixMail
    smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated permit_inet_interfaces reject_unauth_destination check_relay_domains
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = 
    broken_sasl_auth_clients = yes
    fallback_relay = 
    
    
     
  3. falko

    falko Super Moderator Howtoforge Staff Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
     
  4. bscottMD

    bscottMD New Member

    /var/log/mail.err.1

    Code:
    Aug 15 19:03:34 postfixmail postfix/smtpd[29239]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
     
  5. bscottMD

    bscottMD New Member

    Code:
    220 PostfixMail ESMTP Postfix (Ubuntu)
    ehlo mdoor.com
    250-PostfixMail
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH GSSAPI DIGEST-MD5 CRAM-MD5 NTLM PLAIN LOGIN ANONYMOUS
    250-AUTH=GSSAPI DIGEST-MD5 CRAM-MD5 NTLM PLAIN LOGIN ANONYMOUS
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    mail from:test@test.com
    250 2.1.0 Ok
    rcpt to name@domain.com
    501 5.5.4 Syntax: RCPT TO:<address>
    RCPT TO:name@domain.com
    250 2.1.5 Ok
    data
    354 Please start mail input.
    TEST
    .
    250 Mail queued for delivery.
    quit
    221 Closing connection. Good bye.
     
  6. falko

    falko Super Moderator Howtoforge Staff Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Strange... Your smtpd_recipient_restrictions seems to be ok... :confused:
     
  7. tahunasky

    tahunasky New Member

    This is what i have in my postfix/main.cf file:

    Code:
    mydomain = domain.com
    myhostname = tui.$mydomain
    mydestination = $myhostname, mail.$mydomain, localhost, localhost.localdomain
    mynetworks = 127.0.0.0/8, 10.0.0.0/24, localhost
    myorigin = $myhostname
    
    
    smtpd_sender_restrictions = reject_unknown_address
    smtpd_recipient_restrictions =  
        permit_mynetworks, 
        permit_sasl_authenticated, 
        reject_unauth_destination
        reject_invalid_hostname, 
        reject_unauth_pipelining, 
        reject_non_fqdn_sender, 
        reject_non_fqdn_recipient, 
        reject_unknown_sender_domain, 
        reject_unknown_recipient_domain, 
        reject_rbl_client zen.spamhaus.org,
        permit
    
    
     
    Last edited: Aug 18, 2012

Share This Page