Postfix/Dovecot: Recipient address rejected: User unknown in virtual mailbox table

Discussion in 'Installation/Configuration' started by Kanyin, Jun 7, 2012.

  1. Kanyin

    Kanyin New Member

    Hello,

    I've recently set up a mail server with Postfix, Dovecot, Mysql and I'm able to send mail from the server. I am unable to recieve mail however. When testing, I send an email my my gmail account to the server email account and I recieve: Recipient address rejected: User unknown in virtual mailbox table (state 13)

    My mail.log contains the following after a failed send attempt (Note *email removed* is not original text. I removed them):
    Jun 7 06:59:30 localhost postfix/smtpd[8853]: connect from mail-vb0-f41.google.com[209.85.212.41]
    Jun 7 06:59:30 localhost postfix/smtpd[8853]: Anonymous TLS connection established from mail-vb0-f41.google.com[209.85.212.41]: TLSv1 with cipher ECDHE-RSA-RC4-SHA (128/128 bits)
    Jun 7 06:59:30 localhost postgrey[29968]: action=pass, reason=client whitelist, client_name=mail-vb0-f41.google.com, client_address=209.85.212.41, sender=*email removed*, recipient=*email removed*
    Jun 7 06:59:30 localhost postfix/smtpd[8853]: NOQUEUE: reject: RCPT from mail-vb0-f41.google.com[209.85.212.41]: 550 5.1.1 <*email removed*>: Recipient address rejected: User unknown in virtual mailbox table; from=<*email removed*> to=<*email removed*> proto=ESMTP helo=<mail-vb0-f41.google.com>
    Jun 7 06:59:30 localhost postfix/smtpd[8853]: disconnect from mail-vb0-f41.google.com[209.85.212.41]

    UPDATE: I've fixed the server not getting the emails. I forgot to create the account.....I'm now receiving a new error message.

    Jun 7 07:27:42 localhost dovecot: auth-worker: mysql(localhost): Connected to database mail
    Jun 7 07:27:42 localhost dovecot: auth-worker: Error: mysql: Query failed, retrying: Table 'mail.users' doesn't exist
    Jun 7 07:27:42 localhost dovecot: auth-worker: Error: sql(*email removed*): User query failed: Table 'mail.users' doesn't exist (using built-in default user_query: SELECT home, uid, gid FROM users WHERE username = '%n' AND domain = '%d')
    Jun 7 07:27:42 localhost dovecot: lda: Error: user *email removed*: Auth USER lookup failed
    Jun 7 07:27:42 localhost dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information.
    Jun 7 07:27:42 localhost postfix/pipe[8950]: 5A859481F6: to=<*email removed*>, relay=dovecot, delay=0.06, delays=0/0.01/0/0.05, dsn=4.3.0, status=deferred (temporary failure)

    UPDATE: OK the fix for this was to change the user_query in /etc/dovecot/dovecot-sql.conf.ext to the following
    user_query = \
    SELECT '/var/vmail/%d/%n' as home, 'maildir:/var/vmail/%d/%n' as mail, \
    150 AS uid, 8 AS gid, concat('dirsize:storage=', quota) AS quota \
    FROM mailbox WHERE username = '%u' AND active = '1'

    Talking myself through my problems by posting them here really helped lol. Thank you.

    ****One Last Problem*****

    I'm unable to connect to my pop3 server via Outlook to download the messages. This is what the mail.log says when trying to set up the account in Outlook.

    Jun 7 08:24:00 localhost postfix/smtpd[10351]: warning: hostname 97-104-71-152.res.bhn.net does not resolve to address 97.104.71.152: Name or service not known
    Jun 7 08:24:00 localhost postfix/smtpd[10351]: connect from unknown[97.104.71.152]
    Jun 7 08:24:00 localhost postfix/smtpd[10351]: warning: SASL: Connect to private/auth failed: Connection refused
    Jun 7 08:24:00 localhost postfix/smtpd[10351]: fatal: no SASL authentication mechanisms
    Jun 7 08:24:00 localhost postfix/smtpd[10353]: warning: hostname 97-104-71-152.res.bhn.net does not resolve to address 97.104.71.152: Name or service not known
    Jun 7 08:24:00 localhost postfix/smtpd[10353]: connect from unknown[97.104.71.152]
    Jun 7 08:24:00 localhost postfix/smtpd[10353]: warning: SASL: Connect to private/auth failed: Connection refused
    Jun 7 08:24:00 localhost postfix/smtpd[10353]: fatal: no SASL authentication mechanisms
    Jun 7 08:24:01 localhost postfix/master[9095]: warning: process /usr/lib/postfix/smtpd pid 10351 exit status 1
    Jun 7 08:24:01 localhost postfix/master[9095]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Jun 7 08:24:01 localhost postfix/master[9095]: warning: process /usr/lib/postfix/smtpd pid 10353 exit status 1
    Jun 7 08:25:01 localhost postfix/smtpd[10358]: warning: hostname 97-104-71-152.res.bhn.net does not resolve to address 97.104.71.152: Name or service not known
    Jun 7 08:25:01 localhost postfix/smtpd[10358]: connect from unknown[97.104.71.152]
    Jun 7 08:25:01 localhost postfix/smtpd[10358]: warning: SASL: Connect to private/auth failed: Connection refused
    Jun 7 08:25:01 localhost postfix/smtpd[10358]: fatal: no SASL authentication mechanisms
    Jun 7 08:25:01 localhost postfix/smtpd[10359]: warning: hostname 97-104-71-152.res.bhn.net does not resolve to address 97.104.71.152: Name or service not known
    Jun 7 08:25:01 localhost postfix/smtpd[10359]: connect from unknown[97.104.71.152]
    Jun 7 08:25:01 localhost postfix/smtpd[10359]: warning: SASL: Connect to private/auth failed: Connection refused
    Jun 7 08:25:01 localhost postfix/smtpd[10359]: fatal: no SASL authentication mechanisms
    Jun 7 08:25:01 localhost postfix/smtpd[10360]: warning: hostname 97-104-71-152.res.bhn.net does not resolve to address 97.104.71.152: Name or service not known
    Jun 7 08:25:01 localhost postfix/smtpd[10360]: connect from unknown[97.104.71.152]
    Jun 7 08:25:01 localhost postfix/smtpd[10360]: warning: SASL: Connect to private/auth failed: Connection refused
    Jun 7 08:25:01 localhost postfix/smtpd[10360]: fatal: no SASL authentication mechanisms
    Jun 7 08:25:01 localhost postfix/smtpd[10361]: warning: hostname 97-104-71-152.res.bhn.net does not resolve to address 97.104.71.152: Name or service not known
    Jun 7 08:25:01 localhost postfix/smtpd[10361]: connect from unknown[97.104.71.152]
    Jun 7 08:25:01 localhost postfix/smtpd[10361]: warning: SASL: Connect to private/auth failed: Connection refused
    Jun 7 08:25:01 localhost postfix/smtpd[10361]: fatal: no SASL authentication mechanisms
    Jun 7 08:25:02 localhost postfix/master[9095]: warning: process /usr/lib/postfix/smtpd pid 10358 exit status 1
    Jun 7 08:25:02 localhost postfix/master[9095]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Jun 7 08:25:02 localhost postfix/master[9095]: warning: process /usr/lib/postfix/smtpd pid 10359 exit status 1
    Jun 7 08:25:02 localhost postfix/master[9095]: warning: process /usr/lib/postfix/smtpd pid 10360 exit status 1
    Jun 7 08:25:02 localhost postfix/master[9095]: warning: process /usr/lib/postfix/smtpd pid 10361 exit status 1

    UPDATE: Everything is fixed and working. Unfortunately I ran into about a million problems after this one and went on a bug fix spree so I'm not sure how I fixed this problem at the moment. I'll try to help anyway though if anyone comes across this.

    This error was due to me not giving the ability for users to auth with the server. I had ssl and plain text login turned off, configuration error on my part. I enabled those and this problem went away. You'll have to dig around in the dovecot conf to find the exact settings to do it but start there.
     
    Last edited: Jun 7, 2012
  2. TiTex

    TiTex Member

    can you post the output of
    Code:
    dovecot -n
    at the end of the output you should have something like this

    Code:
    >   socket:
         type: listen
        client:
          path: /var/spool/postfix/private/auth
          mode: 432
          user: postfix
          group: postfix	
         master:
           path: /var/spool/postfix/private/auth
           mode: 432
           user: postfix
           group: postfix
     
  3. (O)fer_cz

    (O)fer_cz New Member

    hi, i've got similar problem i can receive mails, but i can't send them everything worked but now, it somehow stopped


    mail.log on mail server

    dovecot -n

    exim setup http://www.howtoforge.com/exim-authenticated-smarthost

    exim log on web server

     
    Last edited: Aug 14, 2012
  4. falko

    falko Super Moderator ISPConfig Developer

    Do you use Postfix or Exim?

    Do you get any error messages? Did you check if your server is blacklisted?
     

Share This Page