Postfix/Dovecot not showing mails

Discussion in 'ISPConfig 3 Priority Support' started by DreDvl, Nov 12, 2013.

  1. DreDvl

    DreDvl New Member

    I installed a new server on a small vps and everything was configured according to
    http://www.howtoforge.com/perfect-server-centos-6.4-x86_64-nginx-dovecot-ispconfig-3-p6

    and the following shows up in the mail log

    Nov 12 18:21:22 sud dovecot: auth: Error: mysql: Query failed, retrying: MySQL server has gone away
    Nov 12 18:21:22 sud dovecot: auth: mysql: Connected to localhost (dbispconfig)
    Nov 12 18:21:23 sud postfix/trivial-rewrite[30366]: warning: do not list domain sud.in in BOTH mydestination and virtual_mailbox_domains
    Nov 12 18:21:23 sud postfix/smtpd[29962]: 2570910FE471: client=cpe-24-27-54-233.tx.res.rr.com, sasl_method=PLAIN, [email protected]$
    Nov 12 18:21:23 sud postfix/cleanup[30368]: 2570910FE471: message-id=<[email protected]>
    Nov 12 18:21:23 sud postfix/qmgr[30639]: 2570910FE471: from=<[email protected]>, size=665, nrcpt=1 (queue active)
    Nov 12 18:21:23 sud postfix/trivial-rewrite[30366]: warning: do not list domain sud.in in BOTH mydestination and virtual_mailbox_domains
    Nov 12 18:21:23 sud postfix/local[30369]: 2570910FE471: to=<[email protected]>, relay=local, delay=0.28, delays=0.24/0.01/0/0.04, dsn=2.0.0, status=sent ($
    Nov 12 18:21:23 sud postfix/qmgr[30639]: 2570910FE471: removed


    I see that the mail has been received when i do a cat /var/mail/username but i cannot see the mail when using webmail/pop3 also i can send mail via the webmail interface or pop3

    I also removed the spam-filtering and antivirus using the following guide:

    http://www.faqforge.com/linux/contr...ilter-and-antivirus-functions-in-ispconfig-3/


    Could you please let me know how to resolve this please ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is the hostname that you used for your server. The hostname has to be a subdmain like we used it in the guide (server1.example.com), you used the domain sud.in instead of a subdomain like server1.sud.in and this causes the mail issue now.

    Change the hostname of the server in the centis network configuration, the postfix main.cf file and the /etc/hosts file from sud.in to a subdomain like server1.sud.in or srv1.sud.in or a similar subdomain. Then add the subdomain that you used to the dns zone sud.in as well so external servers can resolve this subdomain and restart postfix.
     
  3. DreDvl

    DreDvl New Member

    Nov 13 08:39:00 srv1 postfix/qmgr[3121]: 7C6C310FE471: from=<[email protected]>, size=671, nrcpt=1 (queue active)
    Nov 13 08:39:00 srv1 postfix/trivial-rewrite[3223]: warning: do not list domain sud.in in BOTH mydestination and virtual_mailbox_domains
    Nov 13 08:39:00 srv1 postfix/local[3231]: 7C6C310FE471: to=<[email protected]>, relay=local, delay=0.25, delays=0.24/0.01/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
    Nov 13 08:39:00 srv1 postfix/qmgr[3121]: 7C6C310FE471: removed

    [[email protected] ~]$ hostname
    srv1.sud.in


    I did that but still says the same.
    Thanks for your help
     
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    To change the hostname of a server it is not enough to change it in one place.
    There are multiple places, e. g. /etc/mailname, /etc/hostname, maybe /etc/postfix/main.cf etc.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You did not change the hostname in the main.cf like I described in my post.
     
  6. DreDvl

    DreDvl New Member

    I actually did do the change even in postfix/main.cf for myhostname variable; however i hadn't changed the value for mydestination = srv1.sud.in, localhost, localhost.localdomain

    Thank you for your time and help
     

Share This Page