Postfix, Dovecot, MySQL users - issue with SASL

Discussion in 'Server Operation' started by silviap, Jun 16, 2009.

  1. silviap

    silviap New Member

    Hello,

    I installed on a CentOS 5 machine Postfix and Dovecot with MySQL users (I mainly followed this tutorial: http://wiki.dovecot.org/HowTo/DovecotLDAPostfixAdminMySQL). This setup worked for me in the past, but now, I notice I can send emails out, but I cannot receive any.
    In maillog I have:

    postfix/smtpd: warning: SASL: Connect to private/auth failed: Connection refused
    postfix/smtpd: fatal: no SASL authentication mechanisms
    postfix/master: warning: process /usr/libexec/postfix/smtpd pid 7632 exit status 1
    postfix/master: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

    Any suggestions?
    Thanks!
     
  2. falko

    falko Super Moderator

    Did you install any updates recently?
    Have you tried to restart Postfix and saslauthd? What's in your smtpd.conf?
     
  3. silviap

    silviap New Member

    Yes, the server was updated recently (not by me). I restarted all the services, I even re-installed Postfix and Dovecot.
    The /usr/lib/sasl2/smtpd.conf file had the following line:
    pwcheck_method: saslauthd

    The output for "saslauthd -v" is:
    saslauthd 2.1.22
    authentication mechanisms: getpwent kerberos5 pam rimap shadow ldap

    I tried adding mech_list: plain login, but nothing happened.

    Thank you for your help!
     
  4. falko

    falko Super Moderator

    Ok, then you have to rebuild Postfix with MySQL support.
     

Share This Page