Postfix don't deliver email to email forward accounts

Discussion in 'Installation/Configuration' started by albegior, Mar 4, 2016.

  1. albegior

    albegior New Member

    Hello, i'm using ispconfig form many years on debian 8, I have problems with email system on 2 servers. I have configured some email forward on the panel like this: test@servilux.it forward to pippo@gmail.com
    If i send one email to test@servilux.it postfix don't deliver the message to pippo@gmail.com

    The same problem on 2 servers with the same panel version on debian 8

    Could someone help me? Best regards Alberto

    this is the mail.log

    Mar 4 14:13:13 cloud002 postfix/smtpd[17980]: connect from mail-wm0-f52.google.com[74.125.82.52]
    Mar 4 14:13:14 cloud002 postfix/smtpd[17980]: 64F9C7F819: client=mail-wm0-f52.google.com[74.125.82.52]
    Mar 4 14:13:14 cloud002 postfix/cleanup[18355]: 64F9C7F819: message-id=<6BC3E709-3585-4E6E-A99C-C45E1ACD5000@gmail.com>
    Mar 4 14:13:14 cloud002 postfix/qmgr[1845]: 64F9C7F819: from=<pippo@gmail.com>, size=2585, nrcpt=1 (queue active)
    Mar 4 14:13:14 cloud002 postfix/smtpd[17980]: disconnect from mail-wm0-f52.google.com[74.125.82.52]
    Mar 4 14:13:15 cloud002 postfix/smtpd[18359]: connect from localhost.localdomain[127.0.0.1]
    Mar 4 14:13:15 cloud002 postfix/smtpd[18359]: 718927F83D: client=localhost.localdomain[127.0.0.1]
    Mar 4 14:13:15 cloud002 postfix/cleanup[18355]: 718927F83D: message-id=<6BC3E709-3585-4E6E-A99C-C45E1ACD5000@gmail.com>
    Mar 4 14:13:15 cloud002 postfix/qmgr[1845]: 718927F83D: from=<pippo@gmail.com>, size=3071, nrcpt=1 (queue active)
    Mar 4 14:13:15 cloud002 postfix/smtpd[18359]: disconnect from localhost.localdomain[127.0.0.1]
    Mar 4 14:13:15 cloud002 amavis[6004]: (06004-13) Passed CLEAN {RelayedInbound}, [74.125.82.52]:33327 [79.26.241.6] <pippo@gmail.com> -> <test@servilux.it>, Queue-ID: 64F9C7F819, Message-ID: <6BC3E709-3585-4E6E-A99C-C45E1ACD5000@gmail.com>, mail_id: eUx4Oi9o3gUn, Hits: 0.68, size: 2585, queued_as: 718927F83D, 828 ms
    Mar 4 14:13:15 cloud002 postfix/smtp[18356]: 64F9C7F819: to=<test@servilux.it>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.1, delays=0.25/0.01/0.01/0.83, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 718927F83D)
    Mar 4 14:13:15 cloud002 postfix/qmgr[1845]: 64F9C7F819: removed
    Mar 4 14:13:15 cloud002 postfix/smtp[18360]: connect to gmail-smtp-in.l.google.com[2607:f8b0:400d:c02::1a]:25: Network is unreachable
    Mar 4 14:13:16 cloud002 postfix/smtp[18360]: 718927F83D: to=<pippo@gmail.com>, orig_to=<test@servilux.it>, relay=gmail-smtp-in.l.google.com[173.194.205.27]:25, delay=1, delays=0.01/0.02/0.83/0.15, dsn=2.0.0, status=sent (250 2.0.0 OK 1457097196 c52si3602063qgc.5 - gsmtp)
    Mar 4 14:13:16 cloud002 postfix/qmgr[1845]: 718927F83D: removed
    Mar 4 14:14:01 cloud002 postfix/smtpd[17980]: connect from localhost.localdomain[127.0.0.1]
    Mar 4 14:14:01 cloud002 postfix/smtpd[17980]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Mar 4 14:14:01 cloud002 postfix/smtpd[17980]: disconnect from localhost.localdomain[127.0.0.1]
    Mar 4 14:14:01 cloud002 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<wUZ94zgtrAB/AAAB>
    Mar 4 14:14:01 cloud002 dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<ek594zgteQB/AAAB>
    Mar 4 14:15:01 cloud002 postfix/smtpd[17980]: connect from localhost.localdomain[127.0.0.1]
    Mar 4 14:15:01 cloud002 postfix/smtpd[17980]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Mar 4 14:15:01 cloud002 postfix/smtpd[17980]: disconnect from localhost.localdomain[127.0.0.1]
     
    Last edited: Mar 4, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The reason is that the google email server can not be reached from your server. The problem might be the ipv6 support in the network where your server is located. you can try to turn ipv6 off in postfix by setting:

    inet_protocols = ipv4

    in postfix main.cf and then restart postfix.
     
  3. albegior

    albegior New Member

    Hi Till!
    Solved!
    Now it works fine!!!

    Ciao
    Alberto
     

Share This Page