Postfix, DNS and ehlo

Discussion in 'Server Operation' started by R0l@ndSm0ke, Mar 31, 2007.

  1. R0l@ndSm0ke

    R0l@ndSm0ke New Member

    Well, I've had things going pretty well with the server. I do have some concerns regarding the way my server announces itself on the ehlo. Regardless of which domain I ehlo to it always seems to respond with the host of the master domain.

    I am running Perfect OpenSUSE 10.2 with ISPconfig.

    I have a number of domains setup, but the server was configured around www.frankentech.org.

    I don't even know if this is really a problem, but it seems to me that it could cause some problems with regard to sending email to some domains that require working abuse addresses for the sending domain which I have run into. I can't seem to send email to one edu because it always responds that there is no working abuse address which there is. There is one for each domain.

    Questions? Comments? Suggestions? I'll take it all and like it very much:D :p

    EDIT: One other thing. I am seeing a lot of people trying to access my server through ftp, sshd, etc. Is there a simple way to configure the firewall or server to recognize multiple failed attempts from a certain IP and block that IP?
     
    Last edited: Mar 31, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    That's the normal behaviour.

    Take a look here:
    http://www.howtoforge.com/preventing_ssh_dictionary_attacks_with_denyhosts
    http://www.howtoforge.com/forums/showthread.php?t=5515&highlight=brute force
     

Share This Page