Postfix delivery temporarily suspended...

Discussion in 'Server Operation' started by jedimastermopar, Jul 28, 2010.

  1. jedimastermopar

    jedimastermopar New Member

    I setup a postfix server under ubuntu and I tested it out and worked fine, then I sent a bunch of smessages through it and now I can't get it to send messages outside of my domain. All of the messages are just stuck in the deferred queue

    This is a sample output from mailq

    77D20402C1B 4506 Tue Jul 27 15:52:51 [email protected]
    (delivery temporarily suspended: connect to[]:25: Connection refused)
    [email protected]

    cat hosts localhost mail3 mail3

    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters


    # See /usr/share/postfix/ for a commented, more complete version

    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    readme_directory = no

    # TLS parameters
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtpd_client_connection_count_limit = 0
    local_destination_concurrency_limit = 1000
    default_destination_concurrency_limit = 1000
    # maximal_queue_lifetime = 1

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname =
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination =,,, localhost,
    relayhost =
    mynetworks = [::ffff:]/104 [::1]/128
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all

    snip from mail.log

    Jul 27 15:52:27 mail3 postfix/cleanup[12345]: 7362040112D: message-id=<>
    Jul 27 15:52:27 mail3 postfix/smtp[12350]: connect to[]:25: Connection refused
    Jul 27 15:52:27 mail3 postfix/smtp[12350]: connect to[]:25: Connection refused
    Jul 27 15:52:27 mail3 postfix/smtp[12350]: connect to[]:25: Connection refused
    Jul 27 15:52:27 mail3 postfix/smtp[12350]: 717D140112C: to=<[email protected]>, relay=none, delay=0.01, delays=0.01/0/0/0, dsn=4.4.1, status=deferred (connect to[]:25: Connection refused)

    Any Ideas?
  2. Mark_NL

    Mark_NL New Member

    Check if your ISP allows you to use port 25 on it's network.
    A lot of ISP only allow traffic on port 25 through theire own SMTP servers.
  3. jedimastermopar

    jedimastermopar New Member

    turned out to be a FW setting on our external fw. they set it up with the wrong NAT rule.
  4. Mark_NL

    Mark_NL New Member

    lol, i wanted to put a note about some firewalling in it as well, but i figured you had that covered ;-)
  5. jedimastermopar

    jedimastermopar New Member

    Like seriously, I mean you tell them setup a NAT from here to here with port 25 open and they come up with a completly different internal IP address then what you told them. I just expected it to work.
  6. Mark_NL

    Mark_NL New Member

    hehe, damn those sysadmins! *cough* ;-)

Share This Page