postfix courier not running in ssl mode?

Discussion in 'Server Operation' started by shadowsa, Dec 9, 2005.

  1. shadowsa

    shadowsa New Member

    i followed your instructions a few months ago, and everything was fine, now i have the problem that it seems my postfix is not running in ssl mode, recent things i did was i updated from suse 9.3 to suse 10.0 and after the update courier dissapeared, i reinstalled courier and it seemed to work fine, but later i realized that its not running on ssl, additional to this i was not able to bring my machine online for about 7 days because i had within the update also a network error, where i realized at the end that one port of my hardware router has a hardware problem, my biggest concern is im blacklisted in SORBS, and when i try to mail to some providers it doesnt work i get the message
    Code:
    server refused to talk to me: 554-{mx005} Your address is listed as dynamic on SORBS (dul.dnsbl.sorbs.net)  554 We are currently not accepting connections from such hosts.   (port 25)
    within that there comes more trouble, my isp canceled my internet connection officially 2 months ago, fact is the connection still works and thats why i cant contact my isp to ask to whitelist me, so the question is also, i tried to request at SORBS to whitelist me, but the think what im concerned about is, because i realized it after i requested SORBS to whitelist me, will SORBS contact my isp? if so then i will lose my free connection, and maybe be in trouble, and if so, can i cancel the whitelist request somehow at SORBS?

    thank you in advance
     
  2. shadowsa

    shadowsa New Member

    anybody anything?
     
  3. themachine

    themachine HowtoForge Supporter

    No offense, but I think this is one of the most ridiculous support requests I've ever heard of. ;)

    I would recommend paying for your internet connection... and then asking for support that your entitled to... otherwise your beating a horse that can't really be beaten... or, eh something.

    I suppose the term "you can't have your cake and eat it too" sort of fits.


    Sorry.
     
  4. shadowsa

    shadowsa New Member

    ok im delisted now, please it would be nice if somebody could help me to bring up and back my mailserver in ssl mode, thank you in advance
     
  5. themachine

    themachine HowtoForge Supporter

    Can you post your postfix config "/etc/postfix/main.cf"... you should have something similar to:

    Code:
    # TLS CONFIG
    smtpd_tls_auth_only = no
    smtpd_use_tls = yes
    smtpd_enforce_tls = no
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_cert_file = /etc/ssl/certs/mail.domain.com.crt
    smtpd_tls_key_file = /etc/ssl/keys/mail.domain.com.key
     

Share This Page