Postfix/Courier/Mysql/Squirrelmail slow!

Discussion in 'HOWTO-Related Questions' started by abrichr, Aug 15, 2012.

  1. abrichr

    abrichr New Member

    Hello,

    I followed the guide at http://www.howtoforge.com/virtual-u...urier-mysql-and-squirrelmail-ubuntu-12.04-lts, and after much searching and tweaking, was finally able to get it up and running.

    I currently have two accounts set up, sales@abc.com and andrew@abc.com. Both accounts are able to receive and send mail to/from each other through squirrelmail.

    However, after having set everything up, the server is responding significantly slower than previously. Furthermore, several alarming lines that keep reappearing in /var/mail/mail.log:

    Code:
    amavis[27187]: (27187-14) (!)ClamAV-clamd: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused, retrying (2)
    
    amavis[27187]: (27187-14) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused) at (eval 100) line 375.\n
    
    amavis[27187]: (27187-14) (!!)WARN: all primary virus scanners failed, considering backups
    
    amavis[32136]: Net::Server: Ran out of accept retries!
    
    amavis[27187]: (27187-14) (!)ClamAV-clamscan av-scanner FAILED: /usr/bin/clamscan KILLED, signal 9 (0009) at (eval 100) line 596.
    
    amavis[27187]: (27187-14) (!!)TROUBLE in check_mail: virus_scan FAILED: AV: ALL VIRUS SCANNERS FAILED
    
    amavis[27187]: (27187-14) (!)PRESERVING EVIDENCE in /var/lib/amavis/tmp/amavis-20120814T220242-27187
    
    Failed to connect to socket /tmp/fam--
    
    Regarding the second line, the file does at least exist:

    Code:
    # ls -alh /var/run/clamav/clamd.ctl
    srw-rw-rw- 1 clamav clamav 0 Aug 14 21:56 /var/run/clamav/clamd.ctl
    
    Regarding the last line, I found a post at http://serverfault.com/questions/319112/courier-imapd-failed-to-connect-to-socket-tmp-fam. I changed the primary group of user 'vmail' to 'vmail' with the following command:

    Code:
    usermod -g vmail vmail
    And then restarted postfix and courier, with no change in behaviour.

    Any help would be appreciated!
     
  2. abrichr

    abrichr New Member

    I restarted the server, and it doesn't seem as if there are any more problems relating to amavis or clam. However, the server is still quite slow, and these lines appear very frequently in /var/log/mail.log:


    Code:
    imapd: Failed to connect to socket /tmp/fam--
    imapd: last message repeated 5 times
    
     
    Last edited: Aug 15, 2012
  3. falko

    falko Super Moderator

    Does the server have enough RAM? I think it should have at least 1GB.
     
  4. abrichr

    abrichr New Member

    It only has 512MB. I could certainly upgrade it, but that doesn't address the error in the logfile...
     
  5. falko

    falko Super Moderator

    Why not? It is possible that services don't work correctly if there's not enough RAM.
     

Share This Page