[Postfix+courier+mysql] Postfix Forwards not working?

Discussion in 'Server Operation' started by Bales, Apr 2, 2008.

  1. Bales

    Bales New Member


    I have recently setup Postfix, with Mysql Virtual domains etc. Using Courier, Amavis, Clamav and Spamassassin on Debian Etch.

    I followed Falko's Howto, Which I have done a few times before as well setting up the same configuration and had no problems.

    The Server is working fine, and recieves and delivers mail for virtual users without any issues. Forwards however don't appear to be working.
    The mail comes in, and if there is a virtual mailbox for the user it is delivered to the maildir.. or if it is simply a forward and no mailbox exists for the address it is bounced back with the error that the mailbox does not exist.

    I have checked all the configuration and there are no errors, I have even watched the MYSQL log whilst the mail is recieved and the queries are correct. And the correct information is in the DB.

    Postmap -Q email mysql:/etc/postfix/mysql-virtual_forwardings.cf also returns the correct address.

    Everything appears to be fine, But postfix seems to just be ignoring the forward for some reason!

    Like i said i have set this up before, So i am totally stumped and any help is greatly appreciated. The only thing that is different this time around is postfix is quite newer (2.5.1, last time it was 2.3.8) and i compiled it from source with the quota patch but I followed it exactly as in the howto.

    Thanks in Advance.
    Please help :(
  2. Bales

    Bales New Member

    Just wanted to post an update on this.

    I figured out what was causing it, the receive_override_options = no_address_mappings setting in main.cf

    Looking at the postfix documentation, it seems this is what it is meant to do.. but i am kind of confused as to why?

    I looked at my previous configuration and this setting was set, but forwards work.

    is anyone able to elaborate what this setting achieves? I assume it is to do with the content filter. But I am not sure exactly what it does.

    Does anyone know if the behaviour of this setting has changed in the latest versions of postfix?

    Have I found a bug?

  3. Bales

    Bales New Member

    Ahhh.. Wait, I figured it out.

    I had receive_override_options = no_address_mappings in my main.cf

    But in my master.cf I missed the recieve_override_options :)

    Enabled it all, and it appears to be working fine now!

Share This Page