Postfix, Courier, MySQ

Discussion in 'HOWTO-Related Questions' started by ub007, Aug 26, 2008.

  1. ub007

    ub007 New Member

    Falko Timme,

    I found this How-to to be very useful,Infact its one of the best available on the internet and easy to follow.However the mail system is still not working for me...Initially i thought
    Courier -Imap was the issue when i tried:
    Now,I'm afraid postfix isnt functioning as well.The mailbox is created in /home/vmail/ , isnt it?I sent an email to user david but find that no mailbox is being created in /home/vmail.......I made sure there are no typo errors and followed the tutorial word by word.However i didnt install Amavisd, SpamAssassin and ClamAV,left out web mail as well .But i assume that wouldnt be a problem as far as the basic functionality is concerned,would it?.....

    What am i missing here?What debugging steps do i need to follow now?
     
  2. ub007

    ub007 New Member

    sorry,the cut and paste went wronmg here
     
    Last edited: Aug 26, 2008
  3. ub007

    ub007 New Member

    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    myhostname = inter.surey.ac.uk
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = inter.surey.ac.uk, localhost, localhost.localdomain
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_create_maildirsize = yes
    virtual_mailbox_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $vir$

    These are the domains and user added
    Code:
    INSERT INTO `domains` (`domain`) VALUES ('inter.surey.ac.uk');INSERT INTO `domains` (`domain`) VALUES ('inter.surey.ac.uk');
    INSERT INTO `users` (`email`, `password`, `quota`) VALUES ([email protected]', ENCRYPT('secret'), 10485760);

    Now when i sent mail using
    telnet localhost 25
    mail from:[email protected]
    rcpt to: [email protected]

    the mail is found in /var/mail/david3 //david 3 is my system username
    cat david3
    hi
    welcome

    i think its because my /etc/alias reads readslboro
    postmaster : root
    root: david3 //guess the mail is bounced back to david3

    y isnt the mail being sent to [email protected]?i???
     
  4. ub007

    ub007 New Member

    Finally got it working :)

    Connected to localhost.


    It says * 5 EXISTS could anyone plz tell me how to read them from this telnet session

    Thanks in advance
     

Share This Page