Postfix - connection timed out for one destination only

Discussion in 'Server Operation' started by Groggan, Jul 11, 2014.

  1. Groggan

    Groggan New Member

    Hi all

    I have setup a server running Ubuntu 14.04 behind an ADSL modem with a fixed Ip address.

    All has been working fine except with one person I have been trying to email, my insurance broker!!

    The chunk of the mail log is

    Jul 11 11:18:00 server postfix/smtpd[26309]: connect from localhost[]
    Jul 11 11:18:00 server postfix/smtpd[26309]: AB1BC2BC0841: client=localhost[]
    Jul 11 11:18:00 server postfix/cleanup[26291]: AB1BC2BC0841: message-id=<[email protected]>
    Jul 11 11:18:00 server postfix/qmgr[25721]: AB1BC2BC0841: from=<[email protected]>, size=58289, nrcpt=1 (queue active)
    Jul 11 11:18:00 server postfix/smtpd[26309]: disconnect from localhost[]
    Jul 11 11:18:00 server amavis[2951]: (02951-18) Passed CLEAN {RelayedOutbound}, LOCAL []:50256 [] <[email protected]> -> <[email protected]>, Queue-ID: 435B62BC13DE, Message-ID: <[email protected]>, mail_id: wMxjNzN-NuKn, Hits: -2.878, size: 57800, queued_as: AB1BC2BC0841, 8382 ms
    Jul 11 11:18:00 server postfix/smtp[26297]: 435B62BC13DE: to=<[email protected]>, relay=[]:10024, delay=8.5, delays=0.14/0.02/0/8.4, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[]:10025): 250 2.0.0 Ok: queued as AB1BC2BC0841)
    Jul 11 11:18:00 server postfix/qmgr[25721]: 435B62BC13DE: removed
    Jul 11 11:18:31 server postfix/smtp[26310]: connect to[]:25: Connection timed out

    I have checked both my domain and the recipients domain and neither are blacklisted.

    No problems with any other recipients, just this one.

    I can ping it okay, I can telnet to port 25 of the MX IP address, I can email him through my gmail account.

    Things to check?
  2. srijan

    srijan New Member HowtoForge Supporter

    I checked the IP is in blacklist.

    Please ensure it at link
  3. Groggan

    Groggan New Member

    Good catch srijan.

    It was not there earlier as I checked, although I did find some list somewhere that mentioned a backscatter blacklist.

    I have commented out most of my references to anti-spam and blacklists but it is still being blocked (I restarted postfix after doing so)

    Any ideas as to which setting is still causing this?

Share This Page