Postfix configuration issue with Debian Etch

Discussion in 'Installation/Configuration' started by higene, Aug 5, 2007.

  1. higene

    higene New Member

    I thought I'd be clever and rebuild my mail server(formerly Debian Sarge) and install Debian Etch(using the Perfect guide). The server is chugging along happily, but postfix is not allowing email in to my users. I set up Maildirs and can receive local email, but outside emails to my [email protected] are blocked. The message is relay access denied. I should know how to fix this, but several hours of lurking through the forum archive later, I must admit that I could use some expert advice. Sending email from my pop3 client is working properly.

    Here is my postconf -n output:
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    home_mailbox = Maildir/
    inet_interfaces = all
    inet_protocols = all
    mailbox_command =
    mailbox_size_limit = 0
    mydestination = brat01.brat.com, localhost.brat.com, localhost.localdomain, localhost
    myhostname = brat01.brat.com
    mynetworks = 127.0.0.0/8
    myorigin = /etc/mailname
    recipient_delimiter = +
    relayhost =
    smtp_tls_note_starttls_offer = yes
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom


    Thank you in advance. Your forum is invaluable to the community.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    I don't see any virtual_maps directive in your Postfix configuration...

    Do you use ISPConfig?
     
  3. higene

    higene New Member

    I am not using ISPconfig. I had set it up under Sarge, but with a single domain to administer, I thought it was more than I needed.

    I find that if I add mydomain.com to my mydestination directive, then everything works. Is setting a virtual_maps directive a better technique?

    Thanks for the feedback.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Take a look here to find out how to create email accounts from the command line: http://www.howtoforge.com/forums/showthread.php?t=2
     

Share This Page