postfix configuration error! any idea?

Discussion in 'HOWTO-Related Questions' started by pier17, Jan 15, 2007.

  1. pier17

    pier17 New Member

    hi all,

    I am installing postfix by taking the steps in the howtos "Postfix Spam Filter using Ubuntu Dapper, MailScanner, SpamAssassin, Razor, Pyzor, DCC and ClamAV"

    but at the end I have an error when I installed MRTG mail scanner;

    root@smtp-gw:/# env LANG=C /usr/bin/mrtg /etc/mailscanner-mrtg.cfg
    ERROR: Creating templock /var/lock/mrtg/_etc_mailscanner-mrtg.cfg_l_3802: No such file or directory at /usr/bin/mrtg line 1645.

    do you have any idea How can I fix it?

    thx in advance..
  2. falko

    falko Super Moderator ISPConfig Developer

    Does the directory /var/lock/mrtg exist?
  3. pier17

    pier17 New Member

    no there is no mrtg in /var/lock ...there is only apache2 in that directory...
    Last edited: Jan 16, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    mkdir /var/lock/mrtg
    and try again.
  5. pier17

    pier17 New Member

    Hi ,

    thank you for relply,

    I created directory /var/lock.mrtg

    but this time it gives the error;

    root@smtp-gw:/# env LANG=C /usr/bin/mrtg /etc/mailscanner-mrtg.cfg
    ERROR: I guess another mrtg is running. A lockfile (/var/lock/mrtg/_etc_mailscanner-mrtg.cfg_l) aged
    11 seconds is hanging around. If you are sure that no other mrtg
    is running you can remove the lockfile

    also in the logs I get;

    >>smtp-gw MailScanner-MRTG[5403]: ERROR: iptraffic counters not fully initialised - no iptraffic data on this run. This is normal on the first run, or when the previous run was more than 5 minutes ago (e.g. when rebooting). If these errors persist over multiple runs please check that snmpd is running on your system. If you don't want to run snmp please ensure that you have disabled it in mailscanner-mrtg.conf. For more hints about snmp see README.SNMP in the docs directory

    what should I do ?
  6. falko

    falko Super Moderator ISPConfig Developer

    It seems another mrtg process is already running.
    I'd do a reboot and see if the problem comes up again.

Share This Page