Postfix - Can't send or receive email

Discussion in 'Server Operation' started by Blaasbalg, May 12, 2009.

  1. Blaasbalg

    Blaasbalg Member

    Hi,

    My postfix server doesn't work properly.
    I can't receive nor send email.

    Because I'm new with email servers, I don't really know where to begin searching for the problem.
    To setup the postfix server, I followed the The Perfect Server - Fedora 10 tutorial.

    Where to begin?

    Kind Regards,
    Thomas
     
  2. topdog

    topdog New Member HowtoForge Supporter

    begin by looking for errors in /var/log/maillog
     
  3. Blaasbalg

    Blaasbalg Member

    I see a lot of connection time-outs in the log file.
    It also tries to send the email with an invalid address: admispconfig@server1.domain.net

    Strange... I did not send the email with that address... it doesn't even exist.
     
  4. topdog

    topdog New Member HowtoForge Supporter

    Unless you post the error messages here i can not help.
     
  5. Blaasbalg

    Blaasbalg Member

    Ok, here it is:

    Code:
    May 11 21:17:00 server1 freshclam[2438]: --------------------------------------
    May 11 21:25:08 server1 postfix/postfix-script[3916]: stopping the Postfix mail system
    May 11 21:25:08 server1 postfix/master[2396]: terminating on signal 15
    May 11 21:25:10 server1 postfix/postfix-script[3974]: starting the Postfix mail system
    May 11 21:25:10 server1 postfix/master[3975]: daemon started -- version 2.5.6, configuration /etc/postfix
    May 11 22:15:10 server1 postfix/qmgr[3992]: 6F3EC8A6249: from=<admispconfig@server1.censored.net>, size=810, nrcpt=1 (queue active)
    May 11 22:15:10 server1 postfix/qmgr[3992]: 1FE8A8A624F: from=<admispconfig@server1.censored.net>, size=815, nrcpt=1 (queue active)
    May 11 22:15:41 server1 postfix/smtp[5128]: connect to mx2.hotmail.com[65.55.92.152]:25: Connection timed out
    May 11 22:15:41 server1 postfix/smtp[5130]: connect to mx3.hotmail.com[65.55.37.104]:25: Connection timed out
    May 11 22:16:11 server1 postfix/smtp[5128]: connect to mx2.hotmail.com[65.55.37.88]:25: Connection timed out
    May 11 22:16:11 server1 postfix/smtp[5130]: connect to mx4.hotmail.com[65.55.37.104]:25: Connection timed out
    May 11 22:16:41 server1 postfix/smtp[5128]: connect to mx3.hotmail.com[65.55.37.104]:25: Connection timed out
    May 11 22:16:41 server1 postfix/smtp[5130]: connect to mx1.hotmail.com[65.54.244.136]:25: Connection timed out
    May 11 22:17:11 server1 postfix/smtp[5128]: connect to mx2.hotmail.com[65.54.244.168]:25: Connection timed out
    May 11 22:17:11 server1 postfix/smtp[5130]: connect to mx1.hotmail.com[65.55.92.136]:25: Connection timed out
    May 11 22:17:41 server1 postfix/smtp[5128]: connect to mx4.hotmail.com[65.55.37.104]:25: Connection timed out
    May 11 22:17:41 server1 postfix/smtp[5130]: connect to mx3.hotmail.com[65.54.244.72]:25: Connection timed out
    May 11 22:17:41 server1 postfix/smtp[5128]: 6F3EC8A6249: to=<censored@live.nl>, relay=none, delay=148261, delays=148110/0.22/150/0, dsn=4.4.1, status=deferred (connect to mx4.hotmail.com[65.55.37.104]:25: Connection timed out)
    May 11 22:17:41 server1 postfix/smtp[5130]: 1FE8A8A624F: to=<censored@live.nl>, relay=none, delay=148107, delays=147957/0.17/150/0, dsn=4.4.1, status=deferred (connect to mx3.hotmail.com[65.54.244.72]:25: Connection timed out)
    May 11 22:17:54 server1 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    May 11 22:17:54 server1 postfix/smtpd[5218]: connect from localhost.localdomain[127.0.0.1]
    May 11 22:17:54 server1 postfix/smtpd[5218]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    May 11 22:17:54 server1 postfix/smtpd[5218]: disconnect from localhost.localdomain[127.0.0.1]
    May 11 22:18:14 server1 postfix/smtpd[5218]: table hash:/etc/postfix/virtusertable(0,lock|fold_fix) has changed -- restarting
    May 11 22:18:14 server1 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    May 11 22:18:14 server1 postfix/smtpd[5444]: connect from localhost.localdomain[127.0.0.1]
    May 11 22:18:14 server1 postfix/smtpd[5444]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    May 11 22:18:14 server1 postfix/smtpd[5444]: disconnect from localhost.localdomain[127.0.0.1]
     
  6. topdog

    topdog New Member HowtoForge Supporter

    That indicates that your service provider is blocking port 25 connections outbound from you. I am guessing they will only allow you to relay mail through then, which means you need to find out what their relay servers are and use them as smarthosts.
     
  7. Blaasbalg

    Blaasbalg Member

    Unfortunately the service provider doesn't have a relay server.
    They do have a smtp server however, but that's not the same I guess?

    Although I tried using it, and sending email via my own mail server works fine then, but receiving email still doesn't work.
     
  8. topdog

    topdog New Member HowtoForge Supporter

    It is the same thing, for receiving have you created MX records to point to your server ? You also need to check that they are not blocking port 25 inbound.
     
  9. Blaasbalg

    Blaasbalg Member

    As far as I know they don't block port 25.

    My current DNS records are:
    MX smtp.provider.nl (Priority 10)
    MX mail.myowndomain.net (Priority 20)
     
  10. mikelangelo11

    mikelangelo11 New Member

    you should have a line similar to this:10024 is the default port that amavisd-new listens on,
    content_filter = amavis:[127.0.0.1]:10024
    in the output of
    postconf -n
     

Share This Page