postfix can't find user

Discussion in 'Installation/Configuration' started by Machtyn, Oct 28, 2011.

  1. Machtyn

    Machtyn New Member

    I followed the guide here: Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (CentOS 6.0 x86_64) and everything seems to be working properly.

    I set up an account admin at

    I sent a test email using mailx and then attempted to login. Unfortunately, everytime I try to login using either the raw telnet connection or the SquirrelMail web access, I have trouble. Finding that the imap was having trouble changing directory (chdir admin/admin/: No such file or directory) and knowing that the server is supposed to create the directory, I check my /var/log/maillog file. What I see is (with the timestamp and servername removed):
    clamd[27102]: SelfCheck: Database status OK.
    postfix/pickup[3196]: 7496138C8: uid=0 from=<root>
    postfix/cleanup[3220]: 7496138C8: message-id=<[email protected]>
    postfix/qmgr[27200]: 7496138C8: from=<[email protected]>, size=450, nrcpt=1 (queue active)
    postfix/smtpd[3231]: connect from unknown[]
    postfix/smtpd[3231]: 4721B38CB: client=unknown[]
    postfix/cleanup[3220]: 4721B38CB: message-id=<[email protected]>
    postfix/qmgr[27200]: 4721B38CB: from=<[email protected]>, size=898, nrcpt=1 (queue active)
    amavis[32378]: (32378-01) Passed CLEAN, <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: SUT6LVtW2Fdb, Hits: 0.799, size: 450, queued_as: 4721B38CB, 5814 ms
    postfix/smtp[3224]: 7496138C8: to=<[email protected]>, relay=[]:10024, delay=5.9, delays=0.03/0/0.01/5.8, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=32378-01, from MTA([]:10025): 250 2.0.0 Ok: queued as 4721B38CB)
    postfix/qmgr[27200]: 7496138C8: removed
    postfix/virtual[3238]: 4721B38CB: to=<[email protected]>, relay=virtual, delay=0.04, delays=0.01/0.02/0/0.01, dsn=5.1.1, status=bounced (unknown user: "[email protected]")
    postfix/cleanup[3220]: 50BC438CC: message-id=<[email protected]>
    postfix/qmgr[27200]: 50BC438CC: from=<>, size=2846, nrcpt=1 (queue active)
    postfix/bounce[3240]: 4721B38CB: sender non-delivery notification: 50BC438CC
    postfix/qmgr[27200]: 4721B38CB: removed
    postfix/cleanup[3220]: 5444138C8: message-id=<[email protected]>
    postfix/qmgr[27200]: 5444138C8: from=<>, size=2992, nrcpt=1 (queue active)
    postfix/local[3242]: 50BC438CC: to=<[email protected]>, relay=local, delay=0.02, delays=0.01/0.01/0/0.01, dsn=2.0.0, status=sent (forwarded as 5444138C8)
    postfix/qmgr[27200]: 50BC438CC: removed
    postfix/virtual[3238]: 5444138C8: to=<[email protected]>, orig_to=<[email protected]>, relay=virtual, delay=0.01, delays=0.01/0/0/0.01, dsn=5.1.1, status=bounced (unknown user: "[email protected]")
    postfix/qmgr[27200]: 5444138C8: removed
    Okay, so I've got something wrong with my database entries (I think). Oh, by the way, the FQDN is - if that's important.

    Here are my entries:
    mysql> SELECT email, quota FROM users;
    | email | quota  |
    | admin | 262144 |
    1 row in set (0.00 sec)
    mysql> SELECT * FROM domains;
    | domain       |
    | |
    1 row in set (0.00 sec)
    What am I missing? What else do I need to check? Does there happen to be a connection error with a component?

    Thank you very much.
    Last edited: Oct 28, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post your

    Is admin listed in /etc/passwd?
  3. Machtyn

    Machtyn New Member

    passwd and

    [machtyn@alvinadams ~]$ sudo cat /etc/passwd | grep admin
    [machtyn@alvinadams ~]$
    Find the attached. I am wanting to use virtual users for this server. (End goal is to have SOGo installed.)

    Attached Files:

  4. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. What are the outputs of
    hostname -f
    ? What's in /etc/hosts?
  5. Machtyn

    Machtyn New Member

    [machtyn@alvinadams ~]$ hostname
    [machtyn@alvinadams ~]$ hostname -f
    [machtyn@alvinadams ~]$ cat /etc/hosts   localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
    [machtyn@alvinadams ~]$
    I updated the /etc/hosts file to include the ip address for my computer and its hostname and hostname.domainname.

    I decided to try and send again using "mailx [email protected]" and this is what I got in the maillog:
     clamd[27102]: SelfCheck: Database status OK.
    postfix/pickup[9282]: CF7D838CB: uid=500 from=<machtyn>
    postfix/cleanup[9455]: CF7D838CB: message-id=<[email protected]>
    postfix/qmgr[27200]: CF7D838CB: from=<[email protected]>, size=446, nrcpt=1 (queue active)
    amavis[32378]: (32378-02) NOTICE: reconnecting in response to: err=2006, HY000, DBD::mysql::st execute failed: MySQL server has gone away at (eval 100) line 166, <GEN33> line 4.
    postfix/smtpd[9466]: connect from unknown[]
    postfix/smtpd[9466]: 9E08438C8: client=unknown[]
    postfix/cleanup[9455]: 9E08438C8: message-id=<[email protected]>
    postfix/qmgr[27200]: 9E08438C8: from=<[email protected]>, size=894, nrcpt=1 (queue active)
    postfix/smtpd[9466]: disconnect from unknown[]
    amavis[32378]: (32378-02) Passed CLEAN, <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: KSGJDun9pOrX, Hits: 0.799, size: 446, queued_as: 9E08438C8, 5802 ms
    postfix/smtp[9460]: CF7D838CB: to=<[email protected]>, relay=[]:10024, delay=5.8, delays=0.03/0/0/5.8, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=32378-02, from MTA([]:10025): 250 2.0.0 Ok: queued as 9E08438C8)
    postfix/qmgr[27200]: CF7D838CB: removed
    postfix/virtual[9473]: 9E08438C8: to=<[email protected]>, relay=virtual, delay=0.05, delays=0.02/0.02/0/0.01, dsn=5.1.1, status=bounced (unknown user: "[email protected]")
    postfix/cleanup[9455]: A912F38CC: message-id=<[email protected]>
    postfix/qmgr[27200]: A912F38CC: from=<>, size=2845, nrcpt=1 (queue active)
    postfix/bounce[9475]: 9E08438C8: sender non-delivery notification: A912F38CC
    postfix/qmgr[27200]: 9E08438C8: removed
    postfix/local[9477]: A912F38CC: to=<[email protected]>, relay=local, delay=0.02, delays=0.01/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
    postfix/qmgr[27200]: A912F38CC: removed
    [machtyn@alvinadams ~]$ sudo ls /home/vmail/
    You have new mail in /var/spool/mail/machtyn
    What I found curious is that the system notified me I got mail. That hadn't happened before. But then, I was running in sudu -i mode previously when I did this.

    Finally, I did find this thread: that has a similar error as the one I've listed above. I'll try using its suggestions and get back here. Namely, putting mysql to listening on all ifaces and modifying the file for the maildrop option.

    If there is something else, feel free to let me know. Thanks!
    Last edited: Oct 30, 2011
  6. Machtyn

    Machtyn New Member

    also, for what it's worth, here is my file before i try to edit using those suggestions.

    Attached Files:

Share This Page