Postfix Cannot Receive Email - Smtp Timed Out

Discussion in 'Installation/Configuration' started by newbielinx, Sep 25, 2011.

  1. newbielinx

    newbielinx New Member

    Hi everyone,

    having problems on OS centos 5.6/5.7 - postfix - dovecot - I setup my postfix using this tutorial

    1. I can send email to any domain but cannot received any email from external domain (but strange I can receive email from test server - look below).
    2. I can send and received email between local account (using webmin and squirrelmail).
    3. I cannot connect to my smtp server using thunderbird on port 25 or 110 (always timed out).

    What info should I provide?

    here's postfix config
    I'm able to test my server AND SUCCESS using this

    I received the email "SMTP Test Message" on my mailbox [email protected]

    When I connect to 25 or 995 nothing changed in maillog.
    When I send email to [email protected] from gmail or yahoo no changes on the log.

    Also checking my computer IP using [not listed on blacklist]

    netstat -nalp | grep master | grep "LISTEN "
    host -t MX
    host -t mx
    Trying to send email to [email protected] here's the log
    Send email again (this time from gmail) [email protected] to supp@[B]mail[/B]
    - SUCCESS Email received on mailbox

    Send again from gmail but this time to [email protected](without mail.)
    Nothing on the log (FAIL)

    I just changed my mx record from "mail" to "@" on cloudflare and see how it goes. And I still don't understand why the email from [email protected] rejetcted.

    Problem solved now I can received and and send from and to any local and external email host
    here's the solution:
    changed mydestination to mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain

    One more problem... can't connect to my smtp
    Last edited: Sep 25, 2011
  2. Mark_NL

    Mark_NL New Member

    It got rejected because it looks to me you want to mail to, but you send mail to which is mostlikely not defined as your "mydestination" hence postfix will say "i won't relay this mail for you!" (relay access denied)
  3. newbielinx

    newbielinx New Member

    @mark NL

    I can receive any email and send email anywhere (local or external) the only problem I have now is I can only use squirrelmail, webmin mail, etc but not smpt on my computer (outlook, thunderbird, etc)
  4. Mark_NL

    Mark_NL New Member

    Does your provider allow you to send mail through another server that is not owned by them? Alot of ISP's block port 25 on their networks.

    So you could try submission ..

    uncomment the submission lines in of your postfix installation, then restart postfix and try to connect with port 587 instead of 25 (i think you need to enable TLS as well on the client)
  5. newbielinx

    newbielinx New Member

    Updating my iptables.. problem solved.

    Thank you Mark.

    I see no button to mark the thread solved or there is no button?

Share This Page