postfix can send mail in outlook

Discussion in 'Server Operation' started by bambino, Dec 30, 2010.

  1. bambino

    bambino New Member


    I have set up a postfix server with virtual domains. When i test via telnet everything goes well i can send and receive messages. So far so good.

    Now i have created a email account in outlook express and have marked "authorization is required". I can receive mails now in outlook but i am unable to send any mails.

    When i check my log files i get this:


    Dec 30 10:58:36 server postfix/smtpd[19060]: auxpropfunc error invalid parameter supplied
    /var/log/maillog (my ip is my own ip adress)

    Dec 30 10:58:36 server postfix/smtpd[19060]: warning: my-ip: hostname verification failed: Name or service not known
    Dec 30 15:58:36 server postfix/smtpd[19060]: connect from unknown[my-ip]
    Dec 30 15:58:36 server postfix/smtpd[19060]: lost connection after UNKNOWN from unknown[my-ip]
    Dec 30 15:58:36 server postfix/smtpd[19060]: disconnect from unknown[my-ip]
    I have tried everything i can think of to solve this problem but after 1 week of trying i still have the same error and cant send mails via outlook.

    This is my postfix (mydomain in my real file offcourse changed to my real domain)

    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    broken_sasl_auth_clients = yes
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    content_filter = amavis:[]:10024
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    html_directory = no
    inet_interfaces = all
    mail_owner = postfix
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination =, localhost, localhost.localdomain
    myhostname =
    mynetworks =,
    newaliases_path = /usr/bin/newaliases.postfix
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    receive_override_options = no_address_mappings
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    transport_maps = proxy:mysql:/etc/postfix/
    unknown_local_recipient_reject_code = 550
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/, mysql:/etc/postfix/
    virtual_gid_maps = static:5000
    virtual_mailbox_base = /home/vmail
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/
    virtual_minimum_uid = 5000
    virtual_uid_maps = static:5000
    ps aux|grep sasl is showing:

    root      4033  0.0  0.0   5688   704 ?        Ss   09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
    root      4034  0.0  0.0   5688   436 ?        S    09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
    root      4036  0.0  0.0   5688   424 ?        S    09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
    root      4037  0.0  0.0   5688   424 ?        S    09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
    root      4038  0.0  0.0   5688   424 ?        S    09:19   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
    root     28010  0.0  0.0   4112   724 pts/0    S+   11:13   0:00 grep sasl
    Im using port 25 for smtp which is open. i also tried changing to port 2525 and agina both work when i send and check mails via telnet but both dont let me send email via outlook

    Anyone any suggestions what i can do to fix this problem ?


    Last edited: Dec 30, 2010
  2. falko

    falko Super Moderator ISPConfig Developer

    Which tutorial exactly (URL) did you use?
  3. bambino

    bambino New Member

    Hi there,

    I dont have the url anymore but it was a tutorial including a setup of postfix with courier, clamav and spamassassin with virtual domains.


  4. bambino

    bambino New Member

    hi, i solved the problem and am now able to send mails.

    i changed smtpd_sasl_auth_enable = yes to no and placed my own ip in my networks.



Share This Page